mpd: bump to version 0.19.14
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Mar 2016 17:50:30 +0000 (14:50 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 25 Mar 2016 19:53:16 +0000 (20:53 +0100)
0003-thread-Posix-Mutex-Cond-use-constexpr-only-with-glib.patch is
upstream so remove it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/0003-configure.ac-check-if-libatomic-is-needed.patch [new file with mode: 0644]
package/mpd/0003-thread-Posix-Mutex-Cond-use-constexpr-only-with-glib.patch [deleted file]
package/mpd/0005-configure.ac-check-if-libatomic-is-needed.patch [deleted file]
package/mpd/mpd.hash
package/mpd/mpd.mk

diff --git a/package/mpd/0003-configure.ac-check-if-libatomic-is-needed.patch b/package/mpd/0003-configure.ac-check-if-libatomic-is-needed.patch
new file mode 100644 (file)
index 0000000..a9873a7
--- /dev/null
@@ -0,0 +1,40 @@
+From 8eaf14a17244aaf000b4d19e4fde4a637576939f Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Sun, 7 Feb 2016 21:40:47 +0100
+Subject: [PATCH] configure.ac: check if libatomic is needed
+
+The mpd source code uses the C++11 <atomic> functionality, which
+internally is implemented using the __atomic_*() gcc built-ins. On
+certain architectures, the __atomic_*() built-ins are implemented in
+the libatomic library that comes with the rest of the gcc runtime. Due
+to this, code using <atomic> might need to link against libatomic,
+otherwise one hits build issues such as:
+
+GlobalEvents.cxx:(.text._ZN12GlobalEvents4EmitENS_5EventE+0x14): undefined reference to `__atomic_fetch_or_4'
+
+on an architecture like SPARC.
+
+To solve this, a configure.ac check is added to know if we need to
+link against libatomic or not.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 107b45a..8e6fab7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -233,6 +233,8 @@ if test x$have_pthread_setname_np = xyes; then
+       AC_DEFINE(HAVE_PTHREAD_SETNAME_NP, 1, [Is pthread_setname_np() available?])
+ fi
++AC_SEARCH_LIBS([__atomic_load_4], [atomic])
++
+ dnl ---------------------------------------------------------------------------
+ dnl Event loop selection
+ dnl ---------------------------------------------------------------------------
+-- 
+2.6.4
+
diff --git a/package/mpd/0003-thread-Posix-Mutex-Cond-use-constexpr-only-with-glib.patch b/package/mpd/0003-thread-Posix-Mutex-Cond-use-constexpr-only-with-glib.patch
deleted file mode 100644 (file)
index 26fd7f6..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-From 42a5f0c4435757505bd515b68c2a27e8f7565f34 Mon Sep 17 00:00:00 2001
-From: Max Kellermann <max@duempel.org>
-Date: Tue, 25 Aug 2015 12:46:12 +0200
-Subject: [PATCH] thread/Posix{Mutex,Cond}: use "constexpr" only with glibc
-
-Apparently all other C libraries are not compatible with "constexpr".
-Those which are not will get a performance penalty, but at least they
-work at all.
-
-[Thomas: taken from upstream commit 75dff6445063d9b49cca126fd661c9abbd680977.]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- src/thread/PosixCond.hxx  | 16 ++++++++--------
- src/thread/PosixMutex.hxx | 16 ++++++++--------
- 2 files changed, 16 insertions(+), 16 deletions(-)
-
-diff --git a/src/thread/PosixCond.hxx b/src/thread/PosixCond.hxx
-index b3fe204..73dbe02 100644
---- a/src/thread/PosixCond.hxx
-+++ b/src/thread/PosixCond.hxx
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (C) 2009-2013 Max Kellermann <max@duempel.org>
-+ * Copyright (C) 2009-2015 Max Kellermann <max@duempel.org>
-  *
-  * Redistribution and use in source and binary forms, with or without
-  * modification, are permitted provided that the following conditions
-@@ -41,9 +41,13 @@ class PosixCond {
-       pthread_cond_t cond;
- public:
--#if defined(__NetBSD__) || defined(__BIONIC__)
--      /* NetBSD's PTHREAD_COND_INITIALIZER is not compatible with
--         "constexpr" */
-+#ifdef __GLIBC__
-+      /* optimized constexpr constructor for pthread implementations
-+         that support it */
-+      constexpr PosixCond():cond(PTHREAD_COND_INITIALIZER) {}
-+#else
-+      /* slow fallback for pthread implementations that are not
-+         compatible with "constexpr" */
-       PosixCond() {
-               pthread_cond_init(&cond, nullptr);
-       }
-@@ -51,10 +55,6 @@ public:
-       ~PosixCond() {
-               pthread_cond_destroy(&cond);
-       }
--#else
--      /* optimized constexpr constructor for sane POSIX
--         implementations */
--      constexpr PosixCond():cond(PTHREAD_COND_INITIALIZER) {}
- #endif
-       PosixCond(const PosixCond &other) = delete;
-diff --git a/src/thread/PosixMutex.hxx b/src/thread/PosixMutex.hxx
-index 5805158..e0fd614 100644
---- a/src/thread/PosixMutex.hxx
-+++ b/src/thread/PosixMutex.hxx
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (C) 2009-2013 Max Kellermann <max@duempel.org>
-+ * Copyright (C) 2009-2015 Max Kellermann <max@duempel.org>
-  *
-  * Redistribution and use in source and binary forms, with or without
-  * modification, are permitted provided that the following conditions
-@@ -41,9 +41,13 @@ class PosixMutex {
-       pthread_mutex_t mutex;
- public:
--#if defined(__NetBSD__) || defined(__BIONIC__)
--      /* NetBSD's PTHREAD_MUTEX_INITIALIZER is not compatible with
--         "constexpr" */
-+#ifdef __GLIBC__
-+      /* optimized constexpr constructor for pthread implementations
-+         that support it */
-+      constexpr PosixMutex():mutex(PTHREAD_MUTEX_INITIALIZER) {}
-+#else
-+      /* slow fallback for pthread implementations that are not
-+         compatible with "constexpr" */
-       PosixMutex() {
-               pthread_mutex_init(&mutex, nullptr);
-       }
-@@ -51,10 +55,6 @@ public:
-       ~PosixMutex() {
-               pthread_mutex_destroy(&mutex);
-       }
--#else
--      /* optimized constexpr constructor for sane POSIX
--         implementations */
--      constexpr PosixMutex():mutex(PTHREAD_MUTEX_INITIALIZER) {}
- #endif
-       PosixMutex(const PosixMutex &other) = delete;
--- 
-2.6.4
-
diff --git a/package/mpd/0005-configure.ac-check-if-libatomic-is-needed.patch b/package/mpd/0005-configure.ac-check-if-libatomic-is-needed.patch
deleted file mode 100644 (file)
index a9873a7..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From 8eaf14a17244aaf000b4d19e4fde4a637576939f Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Sun, 7 Feb 2016 21:40:47 +0100
-Subject: [PATCH] configure.ac: check if libatomic is needed
-
-The mpd source code uses the C++11 <atomic> functionality, which
-internally is implemented using the __atomic_*() gcc built-ins. On
-certain architectures, the __atomic_*() built-ins are implemented in
-the libatomic library that comes with the rest of the gcc runtime. Due
-to this, code using <atomic> might need to link against libatomic,
-otherwise one hits build issues such as:
-
-GlobalEvents.cxx:(.text._ZN12GlobalEvents4EmitENS_5EventE+0x14): undefined reference to `__atomic_fetch_or_4'
-
-on an architecture like SPARC.
-
-To solve this, a configure.ac check is added to know if we need to
-link against libatomic or not.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- configure.ac | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 107b45a..8e6fab7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -233,6 +233,8 @@ if test x$have_pthread_setname_np = xyes; then
-       AC_DEFINE(HAVE_PTHREAD_SETNAME_NP, 1, [Is pthread_setname_np() available?])
- fi
-+AC_SEARCH_LIBS([__atomic_load_4], [atomic])
-+
- dnl ---------------------------------------------------------------------------
- dnl Event loop selection
- dnl ---------------------------------------------------------------------------
--- 
-2.6.4
-
index 85c99bed838811b0f11e7814b2a33b42a87d97ae..e47cefd53a545d81640db09da4bcccdd6e47ae98 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 f1014838fa7ab2d5fe2ef7f4c101d58fdec2c4c13cfbd2462ee146c8e4919a55        mpd-0.19.13.tar.xz
+sha256 2fd23805132e5002a4d24930001a7c7d3aaf55e3bd0cd71af5385895160e99e7        mpd-0.19.14.tar.xz
index 170a27ff978fa183e43726530264a849d6eea49a..9a1c9572a2e9e594d3ea2c3e655ae413187f677f 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 MPD_VERSION_MAJOR = 0.19
-MPD_VERSION = $(MPD_VERSION_MAJOR).13
+MPD_VERSION = $(MPD_VERSION_MAJOR).14
 MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
 MPD_SITE = http://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
 MPD_DEPENDENCIES = host-pkgconf boost libglib2