lttng-tools: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Jan 2012 19:40:03 +0000 (20:40 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 31 Jan 2012 22:46:06 +0000 (23:46 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/lttng-tools/Config.in [new file with mode: 0644]
package/lttng-tools/lttng-tools.mk [new file with mode: 0644]

index ed916053c20d058f7d9171ac7556ed8685e43bc1..7c3eb2e0f34edf898baf3861927d92e9a3f8bb94 100644 (file)
@@ -25,6 +25,7 @@ source "package/lmbench/Config.in"
 source "package/lsof/Config.in"
 source "package/ltp-testsuite/Config.in"
 source "package/lttng-modules/Config.in"
+source "package/lttng-tools/Config.in"
 source "package/ltrace/Config.in"
 source "package/memstat/Config.in"
 source "package/netperf/Config.in"
diff --git a/package/lttng-tools/Config.in b/package/lttng-tools/Config.in
new file mode 100644 (file)
index 0000000..cc74966
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LTTNG_TOOLS
+       bool "lttng-tools"
+       depends on BR2_PACKAGE_LTTNG_MODULES
+       select BR2_PACKAGE_LIBURCU
+       select BR2_PACKAGE_POPT
+       select BR2_PACKAGE_LTTNG_LIBUST
+       help
+         Userspace utilities for the LTTng 2.0 tracing
+         infrastructure.
+
+         Those utilities are required on the target system to start
+         and stop tracing sessions. Analysis of the trace can be done
+         on the host machine using the babeltrace utility. This
+         utility is automatically built by Buildroot in
+         $(O)/host/usr/bin/babeltrace, as a dependency of
+         lttng-tools. However, there is also a lttng-babeltrace
+         package for the target, if babeltrace on the target is
+         interesting.
+
+         http://lttng.org
diff --git a/package/lttng-tools/lttng-tools.mk b/package/lttng-tools/lttng-tools.mk
new file mode 100644 (file)
index 0000000..9e87480
--- /dev/null
@@ -0,0 +1,11 @@
+LTTNG_TOOLS_VERSION = 2.0-pre15
+LTTNG_TOOLS_SITE    = http://lttng.org/files/bundles/20111214/
+LTTNG_TOOLS_SOURCE  = lttng-tools-$(LTTNG_TOOLS_VERSION).tar.bz2
+
+# The host-lttng-babeltrace technically isn't a required build
+# dependency. However, having the babeltrace utilities built for the
+# host is very useful, since those tools allow to convert the binary
+# trace format into an human readable format.
+LTTNG_TOOLS_DEPENDENCIES = liburcu popt host-lttng-babeltrace lttng-libust
+
+$(eval $(call AUTOTARGETS))