moarvm: use host-lua instead of host-luajit
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 3 Nov 2017 15:51:40 +0000 (16:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Nov 2017 20:57:08 +0000 (21:57 +0100)
host-luajit has limited architecture support, and moarvm does not need
anything luajit specific - So use host-lua instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/moarvm/moarvm.mk

index 276fb2c46337d8c771a866003cb87b52fec9b73d..705c93934d4ffd24bcfad9b8e06b421d8c0d8295 100644 (file)
@@ -10,7 +10,7 @@ MOARVM_SOURCE = MoarVM-$(MOARVM_VERSION).tar.gz
 MOARVM_LICENSE = Artistic-2.0
 MOARVM_LICENSE_FILES = Artistic2.txt
 MOARVM_INSTALL_STAGING = YES
-MOARVM_DEPENDENCIES = host-luajit host-pkgconf libuv libtommath libatomic_ops
+MOARVM_DEPENDENCIES = host-lua host-pkgconf libuv libtommath libatomic_ops
 
 MOARVM_CONF_OPTS = \
        --build=$(GNU_HOST_NAME) \
@@ -20,7 +20,7 @@ MOARVM_CONF_OPTS = \
        --ld="$(TARGET_CC)" \
        --prefix="/usr" \
        --pkgconfig=$(PKG_CONFIG_HOST_BINARY) \
-       --lua=$(HOST_DIR)/bin/luajit \
+       --lua=$(HOST_DIR)/bin/lua \
        --has-libuv \
        --has-libtommath \
        --has-libatomic