Fix gst-plugins-bad dependency on openssl through the apexsink element
authorLionel Landwerlin <llandwerlin@gmail.com>
Thu, 10 Dec 2009 21:30:41 +0000 (22:30 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 10 Dec 2009 21:30:41 +0000 (22:30 +0100)
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-bad/Config.in
package/multimedia/gst-plugins-bad/gst-plugins-bad.mk

index 6c5e44895e4fca51c87673841fd8968ffe86892d..180facfc158f189810d517bfec0177499de92f32 100644 (file)
@@ -24,6 +24,10 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AMRPARSE
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ASFMUX
        bool "asfmux"
 
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK
+       bool "apexsink"
+       select BR2_PACKAGE_OPENSSL
+
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT
        bool "autoconvert"
 
index ee7003c8d4fee02b18d4210aaac6d2ce482d094a..9b65198b89979e76bfa2911f1feaf7be2a2bec53 100644 (file)
@@ -39,6 +39,13 @@ else
 GST_PLUGINS_BAD_CONF_OPT += --disable-asfmux
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-apexsink
+GST_PLUGINS_BAD_DEPENDENCIES += openssl
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-apexsink
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-autoconvert
 else