Revert "automake: complete the removal of the target package"
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Feb 2015 23:40:20 +0000 (00:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Feb 2015 23:40:20 +0000 (00:40 +0100)
This reverts commit 6c33512e01acfc576dc4e3ad28def8b29c0db822.

We DO need to look in the staging directory for .m4 files installed by other
target packages, otherwise we'll have breakage like:

http://autobuild.buildroot.net/results/b20/b20e3efcb0be3032781d7b2f0ef4c351834da0ce/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/autoconf/autoconf.mk
package/automake/automake.mk

index 2c0ff30effc32485380a0884aecba8ba61842230..fd91961e85dc2cec6aacd00cad36bd3dcfb45b54 100644 (file)
@@ -23,4 +23,4 @@ $(eval $(host-autotools-package))
 # variables used by other packages
 AUTOCONF = $(HOST_DIR)/usr/bin/autoconf
 AUTOHEADER = $(HOST_DIR)/usr/bin/autoheader
-AUTORECONF = $(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" AUTOPOINT=/bin/true $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)"
+AUTORECONF = $(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" AUTOPOINT=/bin/true $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)" -I "$(ACLOCAL_HOST_DIR)"
index 5021b494b9c1935268b4c3f9de111c7c8e3aa895..a3fd18cd13eac79fc13e929ce1bada73dd3891de 100644 (file)
@@ -28,5 +28,6 @@ $(eval $(host-autotools-package))
 
 # variables used by other packages
 AUTOMAKE = $(HOST_DIR)/usr/bin/automake
-ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
+ACLOCAL_DIR = $(STAGING_DIR)/usr/share/aclocal
+ACLOCAL_HOST_DIR = $(HOST_DIR)/usr/share/aclocal
 ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)