ebtables: new package
authorBaruch Siach <baruch@tkos.co.il>
Mon, 11 Jul 2011 14:33:31 +0000 (17:33 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jul 2011 21:11:55 +0000 (23:11 +0200)
[Peter: add ipv6 dependency]
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/ebtables/Config.in [new file with mode: 0644]
package/ebtables/ebtables.mk [new file with mode: 0644]

index e58254b454589dd11aa61604ad4b70a473a68368..d87dcd8fc1a5eab9372ae3d2abadc63d14d23f61 100644 (file)
@@ -394,6 +394,7 @@ endif
 source "package/dhcpdump/Config.in"
 source "package/dnsmasq/Config.in"
 source "package/dropbear/Config.in"
+source "package/ebtables/Config.in"
 source "package/ethtool/Config.in"
 source "package/hostapd/Config.in"
 source "package/ifplugd/Config.in"
diff --git a/package/ebtables/Config.in b/package/ebtables/Config.in
new file mode 100644 (file)
index 0000000..40bc45c
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_EBTABLES
+       bool "ebtables"
+       depends on BR2_INET_IPV6
+       help
+         Ethernet bridge frame table administration
+
+         http://ebtables.sourceforge.net
+
+comment "ebtables requires a toolchain with IPv6 support"
+       depends on !BR2_INET_IPV6
diff --git a/package/ebtables/ebtables.mk b/package/ebtables/ebtables.mk
new file mode 100644 (file)
index 0000000..67c0d92
--- /dev/null
@@ -0,0 +1,30 @@
+#############################################################
+#
+# ebtables
+#
+#############################################################
+EBTABLES_VERSION = 2.0.10-1
+EBTABLES_SOURCE = ebtables-v$(EBTABLES_VERSION).tar.gz
+EBTABLES_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ebtables
+
+define EBTABLES_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) LIBDIR=/lib/ebtables -C $(@D)
+endef
+
+define EBTABLES_INSTALL_TARGET_CMDS
+       for so in $(@D)/$(EBTABLES_SUBDIR)/*.so \
+               $(@D)/$(EBTABLES_SUBDIR)/extensions/*.so; \
+               do \
+               $(INSTALL) -m 0755 -D $${so} \
+                       $(TARGET_DIR)/lib/ebtables/`basename $${so}`; \
+       done
+       $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/ebtables \
+               $(TARGET_DIR)/sbin/ebtables
+endef
+
+define EBTABLES_UNINSTALL_TARGET_CMDS
+       rm -rf $(TARGET_DIR)/lib/ebtables
+       rm -f $(TARGET_DIR)/sbin/ebtables
+endef
+
+$(eval $(call GENTARGETS,package,ebtables))