systemd: rework network/tty units installation
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Mon, 23 Jun 2014 09:52:06 +0000 (11:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 08:54:57 +0000 (10:54 +0200)
The installation of the network.service and serial-getty.service unit
files are now performed via the <pkg>_INIT_SYSTEMD mechanism instead of
an installation hook.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index f3874dbfc5bef9e2b9b6724c327ec4e18efd25bd..95e72148f87ff923a39e8faed57edfe6f909539e 100644 (file)
@@ -101,6 +101,13 @@ ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPT += --enable-networkd
 else
 SYSTEMD_CONF_OPT += --disable-networkd
+define SYSTEMD_INSTALL_SERVICE_NETWORK
+       $(INSTALL) -D -m 644 package/systemd/network.service \
+               $(TARGET_DIR)/etc/systemd/system/network.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -fs ../network.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/network.service
+endef
 endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_TIMESYNCD),y)
@@ -131,11 +138,6 @@ define SYSTEMD_INSTALL_INIT_HOOK
        ln -fs ../../../lib/systemd/system/multi-user.target $(TARGET_DIR)/etc/systemd/system/default.target
 endef
 
-define SYSTEMD_INSTALL_TTY_HOOK
-       rm -f $(TARGET_DIR)/etc/systemd/system/getty.target.wants/getty@tty1.service
-       ln -fs ../../../../lib/systemd/system/serial-getty@.service $(TARGET_DIR)/etc/systemd/system/getty.target.wants/serial-getty@$(BR2_TARGET_GENERIC_GETTY_PORT).service
-endef
-
 define SYSTEMD_INSTALL_MACHINEID_HOOK
        touch $(TARGET_DIR)/etc/machine-id
 endef
@@ -145,28 +147,25 @@ define SYSTEMD_SANITIZE_PATH_IN_UNITS
                -exec $(SED) 's,$(HOST_DIR),,g' {} \;
 endef
 
-define SYSTEMD_INSTALL_NETWORK_HOOK
-       $(INSTALL) -D -m 644 package/systemd/network.service \
-               $(TARGET_DIR)/etc/systemd/system/network.service
-       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -fs ../network.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/network.service
-endef
-
 SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
        SYSTEMD_INSTALL_INIT_HOOK \
-       SYSTEMD_INSTALL_TTY_HOOK \
        SYSTEMD_INSTALL_MACHINEID_HOOK \
        SYSTEMD_SANITIZE_PATH_IN_UNITS
 
-ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),)
-SYSTEMD_POST_INSTALL_TARGET_HOOKS += SYSTEMD_INSTALL_NETWORK_HOOK
-endif
-
 define SYSTEMD_USERS
        systemd-journal -1 systemd-journal -1 * /var/log/journal - - Journal
        systemd-journal-gateway -1 systemd-journal-gateway -1 * /var/log/journal - - Journal Gateway
        $(SYSTEMD_USER_TIMESYNC)
 endef
 
+define SYSTEMD_INSTALL_SERVICE_TTY
+       rm -f $(TARGET_DIR)/etc/systemd/system/getty.target.wants/getty@tty1.service
+       ln -fs ../../../../lib/systemd/system/serial-getty@.service $(TARGET_DIR)/etc/systemd/system/getty.target.wants/serial-getty@$(BR2_TARGET_GENERIC_GETTY_PORT).service
+endef
+
+define SYSTEMD_INSTALL_INIT_SYSTEMD
+       $(SYSTEMD_INSTALL_SERVICE_TTY)
+       $(SYSTEMD_INSTALL_SERVICE_NETWORK)
+endef
+
 $(eval $(autotools-package))