package/xterm: compile with libXft support when it selected
authorkyak <bas@bmail.ru>
Mon, 27 Jul 2015 14:46:50 +0000 (17:46 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2015 20:54:22 +0000 (22:54 +0200)
When libXft (FreeType) library is selected, xterm will use it.
host-pkgcong is used to search for libXft during configure, so it
is in the dependencies.

Signed-off-by: Mikhail Peselnik <bas@bmail.ru>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Tested-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xterm/xterm.mk

index 778b40cbd836e22ed3b576384810e5ccb5d96950..e7afff210d41459591d7a3a9eca10c0bebddfb64 100644 (file)
@@ -7,11 +7,19 @@
 XTERM_VERSION = 314
 XTERM_SOURCE = xterm-$(XTERM_VERSION).tgz
 XTERM_SITE = ftp://invisible-island.net/xterm
-XTERM_DEPENDENCIES = ncurses xlib_libXaw
+XTERM_DEPENDENCIES = ncurses xlib_libXaw host-pkgconf
 XTERM_LICENSE = MIT
 XTERM_LICENSE_FILES = version.c
 XTERM_CONF_OPTS = --enable-256-color \
        --x-includes=$(STAGING_DIR)/usr/include \
        --x-libraries=$(STAGING_DIR)/usr/lib
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBXFT),y)
+XTERM_DEPENDENCIES += xlib_libXft
+XTERM_CONF_OPTS += --enable-freetype \
+       --with-freetype-config=auto
+else
+XTERM_CONF_OPTS += --disable-freetype
+endif
+
 $(eval $(autotools-package))