sam-ba: correct license
authorBaruch Siach <baruch@tkos.co.il>
Sun, 18 Sep 2016 07:29:58 +0000 (10:29 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Sep 2016 17:28:14 +0000 (19:28 +0200)
The sam-ba binary is distributed under a proprietary license. TCL and some
applets code is under a BSD-2c like license, while some other applets are
under BSD-4c.

Also correct license files.

Cc: Ludovic Desroches <ludovic.desroches@atmel.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sam-ba/sam-ba.mk

index aede615a3f94694dd9104c7aac15ff87ce64dfc1..7fc65c01a9b33fbef70749c4bcbb746c669b65ee 100644 (file)
@@ -7,8 +7,10 @@
 SAM_BA_SITE = http://www.atmel.com/dyn/resources/prod_documents
 SAM_BA_VERSION = 2.16
 SAM_BA_SOURCE = sam-ba_$(SAM_BA_VERSION)_linux.zip
-SAM_BA_LICENSE = BSD-like (partly binary-only)
-SAM_BA_LICENSE_FILES = doc/readme.txt
+SAM_BA_LICENSE = SAM-BA license (sam-ba executable), \
+               BSD-2c like, BSD-4c (TCL and applets code)
+SAM_BA_LICENSE_FILES = doc/license.txt tcl_lib/boards.tcl \
+               applets/sam4c/libraries/libchip_sam4c/include/sam4c/sam4c32e-1.h
 
 define HOST_SAM_BA_EXTRACT_CMDS
        $(UNZIP) -d $(BUILD_DIR) $(DL_DIR)/$(SAM_BA_SOURCE)