util-linux: fix libintl linking if present
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 9 Aug 2011 14:15:22 +0000 (16:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 9 Aug 2011 14:17:16 +0000 (16:17 +0200)
The configure script correctly detects presence of libintl, but it forgets
to link against it, breaking the build.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/util-linux/util-linux.mk

index d34759bfd64d3a6cc2a9b640029909061971eaa9..dd6ee5c6970b93d8d2e10989a23cf02dfb530430 100644 (file)
@@ -25,6 +25,10 @@ else
 UTIL_LINUX_CONF_OPT += --without-ncurses
 endif
 
+ifeq ($(BR2_PACKAGE_LIBINTL),y)
+UTIL_LINUX_DEPENDENCIES += libintl
+UTIL_LINUX_MAKE_OPT += LIBS=-lintl
+endif
 
 #############################################
 #