gstreamer: fix unaligned detection for nios2
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 24 Nov 2015 21:44:47 +0000 (22:44 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 24 Nov 2015 21:46:10 +0000 (22:46 +0100)
Fixes:
http://autobuild.buildroot.net/results/874/874c4da3ca7d27551f580994e016bcbd3597a107/
http://autobuild.buildroot.net/results/f8b/f8ba30408b5ce15022792e823a0c8fd3a004fb31/
http://autobuild.buildroot.net/results/bf2/bf2f374357ed7a36f072d89ed0687c942eb1ee6d/
http://autobuild.buildroot.net/results/14a/14aaac32b92939957a9f39ac2ba8a949f9ddd22a/

Similar to how we do it for arc/xtensa/microblaze.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer/gstreamer/gstreamer.mk

index 1dbd66fdaeca49d349e1131ee142a66544f803ca..d1e328233ff359f1605ef09722251157cec3718c 100644 (file)
@@ -12,7 +12,7 @@ GSTREAMER_INSTALL_STAGING = YES
 # Checking if unaligned memory access works correctly cannot be done when cross
 # compiling. For the following architectures there is no information available
 # in the configure script.
-ifeq ($(BR2_arc)$(BR2_xtensa)$(BR2_microblaze),y)
+ifeq ($(BR2_arc)$(BR2_xtensa)$(BR2_microblaze)$(BR2_nios2),y)
 GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
 endif
 ifeq ($(BR2_aarch64),y)