mii-diag: fix race condition
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Feb 2013 22:47:19 +0000 (23:47 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Feb 2013 22:47:19 +0000 (23:47 +0100)
The mii-diag buildsystem doesn't correctly encode the needed
dependencies, so the install step can race against the mii-diag-udeb
(through all) to either cause mii-diag to be built for the host or
not be available when 'install' is executed.

Work around it by explicitly calling the needed steps and not building
the (unused) udeb version at all.

Fixes http://autobuild.buildroot.net/results/4825d267025c74c522077f84330b47f1110315fa

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/mii-diag/mii-diag.mk

index a4ad4744c93e90a8b34264fcef2cde55bfeafde2..b9d763c85e94712e382c7ece508e4c2cc2135458 100644 (file)
@@ -21,11 +21,11 @@ endef
 MII_DIAG_POST_PATCH_HOOKS = MII_DIAG_DEBIAN_PATCHES
 
 define MII_DIAG_BUILD_CMDS
-       $(MAKE) $(MII_DIAG_MAKE_OPT) -C $(@D)
+       $(MAKE) $(MII_DIAG_MAKE_OPT) -C $(@D) mii-diag
 endef
 
 define MII_DIAG_INSTALL_TARGET_CMDS
-       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install-mii-diag
 endef
 
 define MII_DIAG_UNINSTALL_TARGET_CMDS