package/pkg-luarocks.mk: use custom luarocks config file
authorFrancois Perrad <francois.perrad@gadz.org>
Sun, 12 Apr 2020 12:00:43 +0000 (14:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 12:48:18 +0000 (14:48 +0200)
In preparation for the addition of the support for host-luarocks
packages, this commit changes the luarocks logic to use a custom
configuration file in $(HOST_DIR)/etc/luarocks/config.lua instead of
the default
$(HOST_DIR)/etc/luarocks/config-$(LUAINTERPRETER_ABIVER).lua.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: extracted from a larger patch from François]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luarocks/luarocks.mk
package/pkg-luarocks.mk

index 17360048cdb46a7e5c66d85ba4f72889a4975fb1..cf111e4c912b8306ea53d0d994ae8838b7029d7e 100644 (file)
@@ -12,7 +12,8 @@ LUAROCKS_LICENSE_FILES = COPYING
 HOST_LUAROCKS_DEPENDENCIES = host-luainterpreter
 
 LUAROCKS_CONFIG_DIR = $(HOST_DIR)/etc
-LUAROCKS_CONFIG_FILE = $(LUAROCKS_CONFIG_DIR)/luarocks/config-$(LUAINTERPRETER_ABIVER).lua
+LUAROCKS_CONFIG_FILE_DEFAULT = $(LUAROCKS_CONFIG_DIR)/luarocks/config-$(LUAINTERPRETER_ABIVER).lua
+LUAROCKS_CONFIG_FILE = $(LUAROCKS_CONFIG_DIR)/luarocks/config.lua
 
 define LUAROCKS_ADDON_EXTRACT
        mkdir $(@D)/src/luarocks/cmd/external
@@ -30,9 +31,11 @@ define HOST_LUAROCKS_CONFIGURE_CMDS
 endef
 
 define HOST_LUAROCKS_INSTALL_CMDS
-       rm -f $(LUAROCKS_CONFIG_FILE)
+       rm -f $(LUAROCKS_CONFIG_FILE_DEFAULT)
        $(MAKE1) -C $(@D) install
-       cat $(HOST_LUAROCKS_PKGDIR)/luarocks-br-config.lua >> $(LUAROCKS_CONFIG_FILE)
+       cat $(LUAROCKS_CONFIG_FILE_DEFAULT) $(HOST_LUAROCKS_PKGDIR)/luarocks-br-config.lua \
+               > $(LUAROCKS_CONFIG_FILE)a
+       rm -f $(LUAROCKS_CONFIG_FILE_DEFAULT)
 endef
 
 $(eval $(host-generic-package))
index 23906f4a864ea2920411c95e2252e83faf2eb8c9..a50a4fcf5a767e45926bad4ed667688f107cc71e 100644 (file)
@@ -70,6 +70,7 @@ endif
 ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
        cd $$($(2)_SRCDIR) && \
+               LUAROCKS_CONFIG=$$(LUAROCKS_CONFIG_FILE) \
                $$(LUAROCKS_RUN_CMD) make --keep --deps-mode none \
                        --tree "$$(TARGET_DIR)/usr" \
                        LUA_INCDIR="$$(STAGING_DIR)/usr/include" \