Upgrade to latest, handle endianness automagically
authorEric Andersen <andersen@codepoet.org>
Fri, 24 Jun 2005 10:30:09 +0000 (10:30 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 24 Jun 2005 10:30:09 +0000 (10:30 -0000)
target/squashfs/squashfsroot.mk

index 4fe2f2d4bceb82b8d11768157261364bb948b3e6..358c3bc6af949136755b387078a462a9fbe01d10 100644 (file)
@@ -3,8 +3,8 @@
 # mksquashfs to build to target squashfs filesystems
 #
 #############################################################
-SQUASHFS_DIR=$(BUILD_DIR)/squashfs1.3r3
-SQUASHFS_SOURCE=squashfs1.3r3.tar.gz
+SQUASHFS_DIR=$(BUILD_DIR)/squashfs2.1-r2
+SQUASHFS_SOURCE=squashfs2.1-r2.tar.gz
 SQUASHFS_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/squashfs
 
 $(DL_DIR)/$(SQUASHFS_SOURCE):
@@ -33,6 +33,25 @@ squashfs-dirclean:
 # Build the squashfs root filesystem image
 #
 #############################################################
+SQUASHFS_ENDIANNESS=-le
+ifeq ($(strip $(BR2_armeb)),y)
+SQUASHFS_ENDIANNESS=-be
+endif
+ifeq ($(strip $(BR2_mips)),y)
+SQUASHFS_ENDIANNESS=-be
+endif
+ifeq ($(strip $(BR2_powerpc)),y)
+SQUASHFS_ENDIANNESS=-be
+endif
+ifeq ($(strip $(BR2_sh3eb)),y)
+SQUASHFS_ENDIANNESS=-be
+endif
+ifeq ($(strip $(BR2_sh4eb)),y)
+SQUASHFS_ENDIANNESS=-be
+endif
+ifeq ($(strip $(BR2_sparc)),y)
+SQUASHFS_ENDIANNESS=-be
+endif
 
 squashfsroot: squashfs host-fakeroot makedevs
        -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
@@ -57,8 +76,10 @@ squashfsroot: squashfs host-fakeroot makedevs
        $(STAGING_DIR)/usr/bin/fakeroot \
                -i $(STAGING_DIR)/fakeroot.env \
                -s $(STAGING_DIR)/fakeroot.env -- \
-               $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) \
-               $(IMAGE).squashfs -noappend
+               $(SQUASHFS_DIR)/squashfs-tools/mksquashfs \
+                   $(TARGET_DIR) \
+                   $(IMAGE).squashfs \
+                   -2.0 -noappend $(SQUASHFS_ENDIANNESS)
 
 squashfsroot-source: squashfs-source