package/spice: enable client
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 Dec 2012 06:56:16 +0000 (06:56 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Dec 2012 20:34:13 +0000 (21:34 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/spice/Config.in
package/spice/spice.mk

index 086b1bc483d563885a4ecf32bd68cd0bd7e8b399..aacc779ba5444327083c8d1e46fed2af2f0539ed 100644 (file)
@@ -21,3 +21,16 @@ config BR2_PACKAGE_SPICE
          This package implements the server-part of Spice.
          
          http://www.spice-space.org/
+
+if BR2_PACKAGE_SPICE
+
+comment "client depends on X.org"
+       depends on !BR2_PACKAGE_XORG7
+
+config BR2_PACKAGE_SPICE_CLIENT
+       bool "Enable client"
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXFIXES
+       select BR2_PACKAGE_XLIB_LIBXRANDR
+
+endif # BR2_PACKAGE_SPICE
index 2752b8af76e51bc986369be44cd48fb76f7a4644..2f7fc20d192ef06f3fffcfba8a0ba17d256ef633 100644 (file)
@@ -26,12 +26,18 @@ SPICE_CONF_OPT =            \
   --disable-gui             \
   --disable-opengl          \
   --disable-smartcard       \
-  --disable-client          \
   --disable-automated-tests \
   --without-sasl            \
 
 SPICE_DEPENDENCIES += host-pkgconf
 
+ifeq ($(BR2_PACKAGE_SPICE_CLIENT),y)
+SPICE_CONF_OPT += --enable-client
+SPICE_DEPENDENCIES += xlib_libXfixes xlib_libXrandr
+else
+SPICE_CONF_OPT += --disable-client
+endif
+
 SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
 SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages