package/docker-engine: bump version to 20.10.1
authorChristian Stewart <christian@paral.in>
Wed, 16 Dec 2020 08:00:12 +0000 (00:00 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 30 Dec 2020 08:36:00 +0000 (09:36 +0100)
Additionally, fix the ldflags specification of the package version.

The "autogen" script does not actually configure anything anymore, and
instead exports a LDFLAGS environment variable which we can't
use. Instead, specify the version information via LDFLAGS directly in
the Buildroot makefile, similar to containerd and other packages.

While at it, fix the formatting of the hash file for the LICENSE file
hash.

Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/docker-engine/docker-engine.hash
package/docker-engine/docker-engine.mk

index e7d5932687287083c8026881dc1185bb672c5f8e..2519ddaecd7a1bb49b32ef00cc520e40788ca93c 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 f43331fef1d24e31f43392fc1fed72b48fc17fd432d341d6eb1f68ca11383406  docker-engine-19.03.13.tar.gz
-sha256 7c87873291f289713ac5df48b1f2010eb6963752bbd6b530416ab99fc37914a8  LICENSE
+sha256  f0fda46a82bf8f624eb349370358891d3bc65ef3e320675226f17dba8f62566d  docker-engine-20.10.1.tar.gz
+sha256  7c87873291f289713ac5df48b1f2010eb6963752bbd6b530416ab99fc37914a8  LICENSE
index 7f898680b72920a7fc528185d9f5119eaac8d57f..058960119a0c68a49120a41840fc6cc63a9e3f26 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-DOCKER_ENGINE_VERSION = 19.03.13
+DOCKER_ENGINE_VERSION = 20.10.1
 DOCKER_ENGINE_SITE = $(call github,moby,moby,v$(DOCKER_ENGINE_VERSION))
 
 DOCKER_ENGINE_LICENSE = Apache-2.0
@@ -14,10 +14,13 @@ DOCKER_ENGINE_DEPENDENCIES = host-pkgconf
 DOCKER_ENGINE_GOMOD = github.com/docker/docker
 
 DOCKER_ENGINE_LDFLAGS = \
-       -X main.GitCommit=$(DOCKER_ENGINE_VERSION) \
-       -X main.Version=$(DOCKER_ENGINE_VERSION)
+       -X $(DOCKER_ENGINE_GOMOD)/dockerversion.BuildTime="" \
+       -X $(DOCKER_ENGINE_GOMOD)/dockerversion.GitCommit="buildroot" \
+       -X $(DOCKER_ENGINE_GOMOD)/dockerversion.IAmStatic="false" \
+       -X $(DOCKER_ENGINE_GOMOD)/dockerversion.InitCommitID="" \
+       -X $(DOCKER_ENGINE_GOMOD)/dockerversion.Version="$(DOCKER_ENGINE_VERSION)"
 
-DOCKER_ENGINE_TAGS = cgo exclude_graphdriver_zfs autogen
+DOCKER_ENGINE_TAGS = cgo exclude_graphdriver_zfs
 DOCKER_ENGINE_BUILD_TARGETS = cmd/dockerd
 
 ifeq ($(BR2_PACKAGE_LIBAPPARMOR),y)
@@ -58,16 +61,6 @@ endif
 
 DOCKER_ENGINE_INSTALL_BINS = $(notdir $(DOCKER_ENGINE_BUILD_TARGETS))
 
-define DOCKER_ENGINE_RUN_AUTOGEN
-       cd $(@D) && \
-               BUILDTIME="$$(date)" \
-               VERSION="$(patsubst v%,%,$(DOCKER_ENGINE_VERSION))" \
-               PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" $(TARGET_MAKE_ENV) \
-               bash ./hack/make/.go-autogen
-endef
-
-DOCKER_ENGINE_POST_CONFIGURE_HOOKS += DOCKER_ENGINE_RUN_AUTOGEN
-
 define DOCKER_ENGINE_INSTALL_INIT_SYSTEMD
        $(INSTALL) -D -m 0644 $(@D)/contrib/init/systemd/docker.service \
                $(TARGET_DIR)/usr/lib/systemd/system/docker.service