qt: fix build with ALSA >= 1.1.x
authorAlexander Shiyan <shc_work@mail.ru>
Tue, 9 Aug 2016 07:54:16 +0000 (10:54 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Aug 2016 10:10:48 +0000 (12:10 +0200)
ALSA > 1.1.x are not determined correctly when configuring the library.
A patch, identical to the one used for Qt5, is added to the qt package
to solve this problem.

Signed-off-by: Alexander Shiyan <shc_work@mail.ru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt/qt.hash
package/qt/qt.mk

index 301010cae15bf3a7f0425896c55618db5c1cd063..de81368511f6c27bd5aa9220b22efb0b6842f8cb 100644 (file)
@@ -1,3 +1,4 @@
 # md5 http://download.qt.io/official_releases/qt/4.8/4.8.7/md5sums-4.8.7, sha256 locally computed:
 md5    d990ee66bf7ab0c785589776f35ba6ad                                 qt-everywhere-opensource-src-4.8.7.tar.gz
 sha256 e2882295097e47fe089f8ac741a95fef47e0a73a3f3cdf21b56990638f626ea0 qt-everywhere-opensource-src-4.8.7.tar.gz
+sha256 e03740e20b8dbf52d163d8a4a37125e7c55b59a9a5e7cf7e89a08e07286b6135 b8f98d956501dfa4ce03a137f15d404930a56066.patch
index 47d5b007f040c5f67373ac557c8bcdc03fcb2abf..c2d2e9c280d5421fe8e3a72b6d98ed133989dbc2 100644 (file)
@@ -15,6 +15,9 @@ QT_VERSION_MAJOR = 4.8
 QT_VERSION = $(QT_VERSION_MAJOR).7
 QT_SOURCE = qt-everywhere-opensource-src-$(QT_VERSION).tar.gz
 QT_SITE = http://download.qt-project.org/official_releases/qt/$(QT_VERSION_MAJOR)/$(QT_VERSION)
+# Patch fixing ALSA detection. Taken from Qt5, but applies fine to
+# Qt4.
+QT_PATCH = https://github.com/qtproject/qtbase/commit/b8f98d956501dfa4ce03a137f15d404930a56066.patch
 QT_DEPENDENCIES = host-pkgconf
 QT_INSTALL_STAGING = YES