package/wavpack: bump to version 4.75.2
authorJörg Krause <joerg.krause@embedded.rocks>
Fri, 16 Oct 2015 06:46:41 +0000 (08:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 17 Oct 2015 09:36:59 +0000 (11:36 +0200)
Autoreconf is not necessary anymore.

WavPack "autodetects" CPU type to enable ASM code. However, the assembly code
for ARM is written for ARMv7 only and building WavPack for an ARM-non-v7
architecture will fail. We explicitly enable ASM for the supported
architectures x86, x64 and ARMv7 and disable it for all others.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wavpack/wavpack.hash
package/wavpack/wavpack.mk

index 18dcfbc827a85551b1adf8b0a1ce0d611a34bd1e..f15afc2524de52cca8cab8d8dae8d9850ac280e6 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed hash
-sha256 2cade379b0aba99fbc4e442ccc6dac6c609f6212e46516a083e24c8c364430a4 wavpack-4.70.0.tar.bz2
+sha256 7d31b34166c33c3109b45c6e4579b472fd05e3ee8ec6d728352961c5cdd1d6b0  wavpack-4.75.2.tar.bz2
index c9bae47a41c582de9826c0fbaf44c2f4d1aee43a..02184e331bef6d8186f2183eab257258b8cb6969 100644 (file)
@@ -4,14 +4,22 @@
 #
 ################################################################################
 
-WAVPACK_VERSION = 4.70.0
+WAVPACK_VERSION = 4.75.2
 WAVPACK_SITE = http://www.wavpack.com
 WAVPACK_SOURCE = wavpack-$(WAVPACK_VERSION).tar.bz2
 WAVPACK_INSTALL_STAGING = YES
-# configure not up to date
-WAVPACK_AUTORECONF = YES
 WAVPACK_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),,libiconv)
 WAVPACK_LICENSE = BSD-3c
 WAVPACK_LICENSE_FILES = COPYING
 
+# WavPack "autodetects" CPU type to enable ASM code. However, the assembly code
+# for ARM is written for ARMv7 only and building WavPack for an ARM-non-v7
+# architecture will fail. We explicitly enable ASM for the supported
+# architectures x86, x64 and ARMv7 and disable it for all others.
+ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_ARM_CPU_ARMV7A),y)
+WAVPACK_CONF_OPTS += --enable-asm
+else
+WAVPACK_CONF_OPTS += --disable-asm
+endif
+
 $(eval $(autotools-package))