Some updates from Andrew May adding gdbserver and adjusting gdb
authorEric Andersen <andersen@codepoet.org>
Fri, 15 Nov 2002 09:41:03 +0000 (09:41 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 15 Nov 2002 09:41:03 +0000 (09:41 -0000)
in the hope of better cross-compiling support

make/gdb.mk
make/gdbserver.mk [new file with mode: 0644]

index 0226f3501104705fcf0d06078d904ac31c9cdaa1..bc8a4b757727234a201ab9d7f48de6c0761e3799 100644 (file)
@@ -20,9 +20,11 @@ $(GDB_DIR)/.configured: $(GDB_DIR)/.unpacked
        AR=$(TARGET_CROSS)ar NM=$(TARGET_CROSS)nm \
        LD=$(TARGET_CROSS)ld AS=$(TARGET_CROSS)as \
        ./configure --prefix=/usr \
+           --target=$(GNU_TARGET_NAME) \
            --includedir=$(STAGING_DIR)/include \
            --disable-nls --without-uiout --disable-gdbmi \
            --disable-tui --disable-gdbtk --without-x \
+           --disable-sim --enable-gdbserver \
            --without-included-gettext);
        touch  $(GDB_DIR)/.configured
 
diff --git a/make/gdbserver.mk b/make/gdbserver.mk
new file mode 100644 (file)
index 0000000..f6902e6
--- /dev/null
@@ -0,0 +1,39 @@
+#############################################################
+#
+# gdb
+#
+#############################################################
+
+GDB_SITE:=ftp://ftp.gnu.org/gnu/gdb/
+GDB_DIR:=$(BUILD_DIR)/gdb-5.2
+GDB_SOURCE:=gdb-5.2.tar.gz
+GDB_WDIR:=$(BUILD_DIR)/gdbserver
+
+
+$(GDB_WDIR)/.configured: $(GDB_DIR)/.unpacked
+       (cd $(GDB_WDIR); rm -rf config.cache; CC=$(TARGET_CC1) \
+       AR=$(TARGET_CROSS)ar NM=$(TARGET_CROSS)nm \
+       LD=$(TARGET_CROSS)ld AS=$(TARGET_CROSS)as \
+       $(GDB_DIR)/gdb/gdbserver/configure --prefix=/usr \
+            --target=$(GNU_TARGET_NAME) \
+           --includedir=$(STAGING_DIR)/include \
+           --disable-nls --without-uiout --disable-gdbmi \
+           --disable-tui --disable-gdbtk --without-x \
+           --without-included-gettext);
+       touch  $(GDB_WDIR)/.configured
+
+$(GDB_DIR)/gdb/gdbserver/gdbserver: $(GDB_WDIR)/.configured
+       make CC=$(TARGET_CC1) -C $(GDB_WDIR)
+       $(STRIP) $(GDB_WDIR)/gdbserver
+
+$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_DIR)/gdb/gdbserver/gdbserver
+       install -c $(GDB_WDIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
+
+gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
+
+gdbserver-clean: 
+       make -C $(GDB_WDIR) clean
+
+gdbserver-dirclean: 
+       rm -rf $(GDB_WDIR)
+