package/pkg-meson: handle b_pie
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 28 May 2021 19:17:48 +0000 (21:17 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 May 2021 09:10:00 +0000 (11:10 +0200)
pipewire unconditionally enables b_pie since version 0.3.20 and
https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/abe73c9146cd223b40b22581b1fd58bc044c671e
which will raise the following build failure on m68k since commit
a6d88d3ba5e30e11f4d726f341bc56c1be7c71c9:

/srv/storage/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/m68k-buildroot-linux-uclibc/9.3.0/../../../../m68k-buildroot-linux-uclibc/bin/ld: /srv/storage/autobuild/run/instance-1/output-1/host/m68k-buildroot-linux-uclibc/sysroot/usr/lib/Scrt1.o: in function `lib_main':
(.text+0x4): undefined reference to `__shared_flat_add_library'

Fixes:
 - http://autobuild.buildroot.org/results/c258a2736661af8ea73abeda2503d8682e65f1e2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-meson.mk

index a57820d4d296d6e7cb4e22d17399c5dfb0d0d4f3..a55063d58ed5a396f75cea934690796b30c717fc 100644 (file)
@@ -91,6 +91,7 @@ define $(2)_CONFIGURE_CMDS
                --default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
                --buildtype=$(if $(BR2_ENABLE_DEBUG),debug,release) \
                --cross-file=$$($$(PKG)_SRCDIR)/build/cross-compilation.conf \
+               -Db_pie=$(if $(BR2_TOOLCHAIN_SUPPORTS_PIE),true,false) \
                -Dstrip=false \
                -Dbuild.pkg_config_path=$$(HOST_DIR)/lib/pkgconfig \
                $$($$(PKG)_CONF_OPTS) \