Makefile: auto-target automatically pass --program-prefix=""
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Tue, 9 Aug 2011 22:12:34 +0000 (00:12 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 11 Sep 2011 22:08:13 +0000 (00:08 +0200)
When cross-compiled, some packages incorrectly prefix their executables
with the target tuple.

Fix that by forcing the program prefix to the empty string when calling
./configure, but only when compiling for target, not for host.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index 46ab861c13977ba7d8d1e0f37ba2e5bdb2f4dd59..7f04c3692b8b46e0319642558594e1801b7414b6 100644 (file)
@@ -100,6 +100,7 @@ define $(2)_CONFIGURE_CMDS
                --prefix=/usr \
                --exec-prefix=/usr \
                --sysconfdir=/etc \
+               --program-prefix="" \
                $$(DISABLE_DOCUMENTATION) \
                $$(DISABLE_NLS) \
                $$(DISABLE_LARGEFILE) \