package/libftdi1: fix license
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 24 Nov 2019 18:01:57 +0000 (19:01 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 24 Nov 2019 21:18:12 +0000 (22:18 +0100)
The GPL only applies to the C++ bindings and eeprom utility, which are
conditionally enabled with BR2_PACKAGE_LIBFTDI1_LIBFTDIPP1 and
BR2_PACKAGE_LIBFTDI1_FDTI_EEPROM, respectively.

The COPYING.LIB is indeed the LGPL-2.0, but the source file for
libftdi1 states LGPL-2.1-only, see src/ftdi.c

The src/ftdi_stream.c also bears a notice of the MIT license, so the
library itself is under both LGPL-2.1-only and MIT.

Note: the COPYING.GPL license file may get added twice to the list, but
that is not a problem in practice: it is just copied twice.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - GPL-2.0 also applies to the ftdi_eeprom utility
  - s/ftdipp1/libftdipp1/
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libftdi1/libftdi1.mk

index 014dd8401ebcdd465b007d869dff70e2cc3c17f6..9c3bafdbc025a3e0f8de0513072cd73989a7ce84 100644 (file)
@@ -9,12 +9,14 @@ LIBFTDI1_SOURCE = libftdi1-$(LIBFTDI1_VERSION).tar.bz2
 LIBFTDI1_SITE = http://www.intra2net.com/en/developer/libftdi/download
 LIBFTDI1_INSTALL_STAGING = YES
 LIBFTDI1_DEPENDENCIES = libusb
-LIBFTDI1_LICENSE = LGPL-2.0 (libftdi1), GPL-2.0 with exception (ftdipp1)
-LIBFTDI1_LICENSE_FILES = LICENSE COPYING.GPL COPYING.LIB
+LIBFTDI1_LICENSE = LGPL-2.1 (libftdi1), MIT (libftdi1)
+LIBFTDI1_LICENSE_FILES = LICENSE COPYING.LIB
 LIBFTDI1_CONFIG_SCRIPTS = libftdi1-config
 LIBFTDI1_CONF_OPTS = -DDOCUMENTATION=OFF -DEXAMPLES=OFF
 
 ifeq ($(BR2_PACKAGE_LIBFTDI1_LIBFTDIPP1),y)
+LIBFTDI1_LICENSE += , GPL-2.0 with exception (libftdipp1)
+LIBFTDI1_LICENSE_FILES += COPYING.GPL
 LIBFTDI1_DEPENDENCIES += boost
 LIBFTDI1_CONF_OPTS += -DFTDIPP=ON
 else
@@ -30,6 +32,8 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBFTDI1_FDTI_EEPROM),y)
 # ftdi_eeprom optionally depends on libintl
+LIBFTDI1_LICENSE += , GPL-2.0 (ftdi_eeprom)
+LIBFTDI1_LICENSE_FILES += COPYING.GPL
 LIBFTDI1_DEPENDENCIES += libconfuse $(TARGET_NLS_DEPENDENCIES)
 LIBFTDI1_CONF_OPTS += -DFTDI_EEPROM=ON
 else