sdl2_net: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 22 May 2017 13:13:06 +0000 (15:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 May 2017 21:16:32 +0000 (23:16 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: add entry to DEVELOPERS file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/sdl2_net/Config.in [new file with mode: 0644]
package/sdl2_net/sdl2_net.hash [new file with mode: 0644]
package/sdl2_net/sdl2_net.mk [new file with mode: 0644]

index e4b6644a9fcdb9ff745ab096ab9cdc5177a3f051..fa00dc878b9ad52db81a5912d52a3b58740274d3 100644 (file)
@@ -577,6 +577,7 @@ F:  package/pkg-perl.mk
 F:     package/pkg-luarocks.mk
 F:     package/qemu/
 F:     package/sdl2_mixer/
+F:     package/sdl2_net/
 F:     package/tekui/
 F:     support/scripts/scancpan
 
index 2255b0b869a685792a910d8a96056c7725eb212d..d6b99015545a2ffd92073d68d1c4946687a7c695 100644 (file)
@@ -282,6 +282,7 @@ comment "Graphic libraries"
        source "package/sdl2_gfx/Config.in"
        source "package/sdl2_image/Config.in"
        source "package/sdl2_mixer/Config.in"
+       source "package/sdl2_net/Config.in"
        source "package/sdl2_ttf/Config.in"
 
 comment "Other GUIs"
diff --git a/package/sdl2_net/Config.in b/package/sdl2_net/Config.in
new file mode 100644 (file)
index 0000000..d5e749f
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SDL2_NET
+       bool "sdl2_net"
+       depends on BR2_PACKAGE_SDL2
+       help
+         This is a small sample cross-platform networking library,
+         with a sample chat client and server application. The chat
+         client uses the GUIlib GUI framework library.
+
+         http://www.libsdl.org/projects/SDL_net/
diff --git a/package/sdl2_net/sdl2_net.hash b/package/sdl2_net/sdl2_net.hash
new file mode 100644 (file)
index 0000000..c5f4433
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 15ce8a7e5a23dafe8177c8df6e6c79b6749a03fff1e8196742d3571657609d21  SDL2_net-2.0.1.tar.gz
diff --git a/package/sdl2_net/sdl2_net.mk b/package/sdl2_net/sdl2_net.mk
new file mode 100644 (file)
index 0000000..2fa4a8c
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# sdl2_net
+#
+################################################################################
+
+SDL2_NET_VERSION = 2.0.1
+SDL2_NET_SOURCE = SDL2_net-$(SDL2_NET_VERSION).tar.gz
+SDL2_NET_SITE = http://www.libsdl.org/projects/SDL_net/release
+SDL2_NET_LICENSE = Zlib
+SDL2_NET_LICENSE_FILES = COPYING.txt
+SDL2_NET_INSTALL_STAGING = YES
+SDL2_NET_DEPENDENCIES = sdl2
+
+$(eval $(autotools-package))