package/sane-backends: security bump to version 1.0.27
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 6 Apr 2019 13:59:04 +0000 (15:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Apr 2019 17:13:20 +0000 (19:13 +0200)
- Switch site to gitlab
- Remove second patch (already in version)
- Use new --{with,without}-usb option
- Add hash for license file
- Fix CVE-2017-6318

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sane-backends/0002-Add-missing-sys-types.h-includes.patch [deleted file]
package/sane-backends/0002-sane_backend-add-missing-config.h.patch [new file with mode: 0644]
package/sane-backends/0003-sane_backend-add-missing-config.h.patch [deleted file]
package/sane-backends/sane-backends.hash
package/sane-backends/sane-backends.mk

diff --git a/package/sane-backends/0002-Add-missing-sys-types.h-includes.patch b/package/sane-backends/0002-Add-missing-sys-types.h-includes.patch
deleted file mode 100644 (file)
index 8ab41f1..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-From d33f16f463e888846d69ddfbeeb963d40972b654 Mon Sep 17 00:00:00 2001
-From: Luiz Angelo Daros de Luca <luizluca@gmail.com>
-Date: Thu, 15 Oct 2015 12:35:00 +0900
-Subject: [PATCH] Add missing <sys/types.h> includes
-
-[Thomas: backport from upstream commit
-33495ef9b42a783c8f5f2c056ac5699481d3cc7e, allows to fix the build with
-the musl C library.]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- backend/epsonds-io.c     | 3 +++
- backend/hp5400.c         | 3 +++
- backend/hp5590.c         | 3 +++
- backend/kvs20xx_cmd.h    | 4 ++++
- backend/kvs40xx.h        | 3 +++
- include/sane/sanei_udp.h | 3 +++
- 6 files changed, 19 insertions(+)
-
-diff --git a/backend/epsonds-io.c b/backend/epsonds-io.c
-index 28bacfc..512997d 100644
---- a/backend/epsonds-io.c
-+++ b/backend/epsonds-io.c
-@@ -16,6 +16,9 @@
- #include "sane/config.h"
- #include <ctype.h>
- #include <unistd.h>     /* sleep */
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- #include "epsonds.h"
- #include "epsonds-io.h"
-diff --git a/backend/hp5400.c b/backend/hp5400.c
-index 61de3db..cfa2dc9 100644
---- a/backend/hp5400.c
-+++ b/backend/hp5400.c
-@@ -67,6 +67,9 @@
- #include <stdlib.h>           /* malloc, free */
- #include <string.h>           /* memcpy */
- #include <stdio.h>
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- #define HP5400_CONFIG_FILE "hp5400.conf"
-diff --git a/backend/hp5590.c b/backend/hp5590.c
-index 7b1cd60..5422372 100644
---- a/backend/hp5590.c
-+++ b/backend/hp5590.c
-@@ -48,6 +48,9 @@
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- #include "../include/sane/sane.h"
- #define BACKEND_NAME hp5590
-diff --git a/backend/kvs20xx_cmd.h b/backend/kvs20xx_cmd.h
-index c18b754..4acaf62 100644
---- a/backend/kvs20xx_cmd.h
-+++ b/backend/kvs20xx_cmd.h
-@@ -9,6 +9,10 @@
-    Panasonic KV-S20xx USB-SCSI scanners.
- */
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
-+
- #define COMMAND_BLOCK 1
- #define DATA_BLOCK    2
- #define RESPONSE_BLOCK        3
-diff --git a/backend/kvs40xx.h b/backend/kvs40xx.h
-index fa17163..02e0da6 100644
---- a/backend/kvs40xx.h
-+++ b/backend/kvs40xx.h
-@@ -10,6 +10,9 @@
- #include "../include/sane/config.h"
- #include <semaphore.h>
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- #undef  BACKEND_NAME
- #define BACKEND_NAME kvs40xx
-diff --git a/include/sane/sanei_udp.h b/include/sane/sanei_udp.h
-index c44afdd..e32fc1a 100644
---- a/include/sane/sanei_udp.h
-+++ b/include/sane/sanei_udp.h
-@@ -27,6 +27,9 @@
- #include <netinet/in.h>
- #include <netdb.h>
- #endif
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- extern SANE_Status sanei_udp_open(const char *host, int port, int *fdp);
- extern SANE_Status sanei_udp_open_broadcast(int *fdp);
--- 
-2.7.4
-
diff --git a/package/sane-backends/0002-sane_backend-add-missing-config.h.patch b/package/sane-backends/0002-sane_backend-add-missing-config.h.patch
new file mode 100644 (file)
index 0000000..8e56b02
--- /dev/null
@@ -0,0 +1,49 @@
+From 13aadf79659dd238b618c8be7c1de44960bd5d50 Mon Sep 17 00:00:00 2001
+From: Romain Naour <romain.naour@gmail.com>
+Date: Fri, 11 Nov 2016 22:20:03 +0100
+Subject: [PATCH] sane_backend: add missing config.h
+
+We should include config.h from sanei_backend.h in order to use the
+correct if/else HAVE_FOO.
+
+For some reason with Glibc or uClibc there is no problem but with musl
+we have the following weird issue:
+
+In file included from epsonds.h:41:0,
+                 from epsonds-jpeg.c:18:
+../include/sane/sanei_backend.h:99:33: error: expected ';', identifier or '(' before 'int'
+ # define sigset_t               int
+                                 ^
+../include/sane/sanei_backend.h:99:33: warning: useless type name in empty declaration
+
+That's because HAVE_SIGPROCMASK is not defined although it's correctly
+detected by the configure script.
+
+$ grep config.log
+config.log:#define HAVE_SIGPROCMASK 1
+
+So, include config.h to avoid to redefine sigset_t.
+
+Fixes:
+http://autobuild.buildroot.net/results/9f1/9f1f1cb727b5c5407e69172280a3dee880e55cdf
+
+Signed-off-by: Romain Naour <romain.naour@gmail.com>
+---
+ include/sane/sanei_backend.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/sane/sanei_backend.h b/include/sane/sanei_backend.h
+index 1b5afe2..2a96532 100644
+--- a/include/sane/sanei_backend.h
++++ b/include/sane/sanei_backend.h
+@@ -8,6 +8,7 @@
+  * @sa sanei.h sanei_thread.h
+  */
++#include "../include/sane/config.h"
+ /*
+  * Compiler related options
+-- 
+2.5.5
+
diff --git a/package/sane-backends/0003-sane_backend-add-missing-config.h.patch b/package/sane-backends/0003-sane_backend-add-missing-config.h.patch
deleted file mode 100644 (file)
index 8e56b02..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From 13aadf79659dd238b618c8be7c1de44960bd5d50 Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@gmail.com>
-Date: Fri, 11 Nov 2016 22:20:03 +0100
-Subject: [PATCH] sane_backend: add missing config.h
-
-We should include config.h from sanei_backend.h in order to use the
-correct if/else HAVE_FOO.
-
-For some reason with Glibc or uClibc there is no problem but with musl
-we have the following weird issue:
-
-In file included from epsonds.h:41:0,
-                 from epsonds-jpeg.c:18:
-../include/sane/sanei_backend.h:99:33: error: expected ';', identifier or '(' before 'int'
- # define sigset_t               int
-                                 ^
-../include/sane/sanei_backend.h:99:33: warning: useless type name in empty declaration
-
-That's because HAVE_SIGPROCMASK is not defined although it's correctly
-detected by the configure script.
-
-$ grep config.log
-config.log:#define HAVE_SIGPROCMASK 1
-
-So, include config.h to avoid to redefine sigset_t.
-
-Fixes:
-http://autobuild.buildroot.net/results/9f1/9f1f1cb727b5c5407e69172280a3dee880e55cdf
-
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- include/sane/sanei_backend.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/sane/sanei_backend.h b/include/sane/sanei_backend.h
-index 1b5afe2..2a96532 100644
---- a/include/sane/sanei_backend.h
-+++ b/include/sane/sanei_backend.h
-@@ -8,6 +8,7 @@
-  * @sa sanei.h sanei_thread.h
-  */
-+#include "../include/sane/config.h"
- /*
-  * Compiler related options
--- 
-2.5.5
-
index a7693e25275a31f62cd65c5928aa539b309089e0..ddf82500bba7a1d3f581d8d94088f664352bd67b 100644 (file)
@@ -1,2 +1,5 @@
-# From http://www.sane-project.org/sane-md5sums.txt
-md5 f9ed5405b3c12f07c6ca51ee60225fe7  sane-backends-1.0.25.tar.gz
+# From https://gitlab.com/sane-project/backends/tags/RELEASE_1_0_27
+sha256 293747bf37275c424ebb2c833f8588601a60b2f9653945d5a3194875355e36c9  sane-backends-1.0.27.tar.gz
+
+# Hash for license file
+sha256 dcc100d4161cc0b7177545ab6e47216f84857cda3843847c792a25289852dcaa  COPYING
index ed3b912479fb6534f9913414292424cdf2edd84a..092123e1940b0781f029bace754ae9f91f668dfa 100644 (file)
@@ -4,8 +4,9 @@
 #
 ################################################################################
 
-SANE_BACKENDS_VERSION = 1.0.25
-SANE_BACKENDS_SITE = https://alioth.debian.org/frs/download.php/file/4146
+SANE_BACKENDS_VERSION = 1.0.27
+SANE_BACKENDS_SITE = \
+       https://gitlab.com/sane-project/backends/uploads/a3ba9fff29253a94e84074917bff581a
 SANE_BACKENDS_CONFIG_SCRIPTS = sane-config
 SANE_BACKENDS_LICENSE = GPL-2.0+
 SANE_BACKENDS_LICENSE_FILES = COPYING
@@ -23,9 +24,9 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBUSB),y)
 SANE_BACKENDS_DEPENDENCIES += libusb
-SANE_BACKENDS_CONF_OPTS += --enable-libusb_1_0
+SANE_BACKENDS_CONF_OPTS += --with-usb
 else
-SANE_BACKENDS_CONF_OPTS += --disable-libusb
+SANE_BACKENDS_CONF_OPTS += --without-usb
 endif
 
 ifeq ($(BR2_PACKAGE_JPEG),y)