projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d70e7f4
)
Prevent problems with fakeroot possibly trying to use stale host filesystem
author
Eric Andersen
<andersen@codepoet.org>
Mon, 8 Aug 2005 07:54:28 +0000
(07:54 -0000)
committer
Eric Andersen
<andersen@codepoet.org>
Mon, 8 Aug 2005 07:54:28 +0000
(07:54 -0000)
inodes by carefully regenerating fakeroot.env from package specific files.
target/makedevs/makedevs.mk
patch
|
blob
|
history
diff --git
a/target/makedevs/makedevs.mk
b/target/makedevs/makedevs.mk
index 620b0cdcd6309ca4e9edb6bd33cbef5ab49d8f58..c700dc4168fc1b3bf6e5058bfcedd3692dd11306 100644
(file)
--- a/
target/makedevs/makedevs.mk
+++ b/
target/makedevs/makedevs.mk
@@
-20,6
+20,10
@@
$(STAGING_DIR)/bin/makedevs: $(MAKEDEVS_DIR)/makedevs
$(INSTALL) -m 755 $(MAKEDEVS_DIR)/makedevs $(STAGING_DIR)/bin/makedevs
touch -c $(STAGING_DIR)/bin/makedevs
+$(STAGING_DIR)/fakeroot.env:
+ cat $(STAGING_DIR)/.fakeroot.* > $(STAGING_DIR)/fakeroot.env
+ touch -c $(STAGING_DIR)/fakeroot.env
+
makedevs: $(STAGING_DIR)/bin/makedevs
makedevs-source: