package/exim: fix build with ccache
authorAlejandro González <alejandro.gonzalez.correo@gmail.com>
Sun, 19 Jul 2020 10:29:46 +0000 (12:29 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 19 Jul 2020 16:49:56 +0000 (18:49 +0200)
When using ccache to build the exim package, the HOSTCC value contains
spaces, that are incorrectly interpreted by exim's Makefilei, which uses
the first word of ${CC} to test compiler options. This breaks the build
with "unrecognized option" ccache errors.

Fix that by wrapping the HOSTCC variable in double quotes, as it is done
for other variables that follow.

Signed-off-by: Alejandro González <alejandro.gonzalez.correo@gmail.com>
[yann.morin.1998@free.fr: slight rewording of commit log]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/exim/exim.mk

index 6643abbf6543754132c69ac61576523718ff587c..19a62f497d7e3b34803dbe4c9247b75daa8ed18b 100644 (file)
@@ -123,8 +123,8 @@ endif
 define EXIM_BUILD_CMDS
        $(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) makefile
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/build-br macro_predef \
-               CC=$(HOSTCC) \
-               LNCC=$(HOSTCC) \
+               CC="$(HOSTCC)" \
+               LNCC="$(HOSTCC)" \
                CFLAGS="-std=c99 $(HOST_CFLAGS)" \
                LFLAGS="-fPIC $(HOST_LDFLAGS)"
        $(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \