toolchain-external: bump version of Linaro ARM toolchain to 2017.11
authorRomain Naour <romain.naour@gmail.com>
Thu, 14 Dec 2017 22:54:24 +0000 (23:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Dec 2017 07:58:07 +0000 (08:58 +0100)
https://releases.linaro.org/components/toolchain/binaries/6.4-2017.11

Tested with qemu_arm_vexpress_defconfig.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/toolchain-external-linaro-arm/Config.in
toolchain/toolchain-external/toolchain-external-linaro-arm/toolchain-external-linaro-arm.hash
toolchain/toolchain-external/toolchain-external-linaro-arm/toolchain-external-linaro-arm.mk

index d665b9987481f0eedca3a6cdaa0207d3b5015b60..3acc06013149d61b646abdc0986b30f37915d1b5 100644 (file)
@@ -5,7 +5,7 @@ comment "Linaro toolchains available for Cortex-A + EABIhf"
        depends on !BR2_STATIC_LIBS
 
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
-       bool "Linaro ARM 2017.08"
+       bool "Linaro ARM 2017.11"
        depends on BR2_arm
        depends on !BR2_ARCH_NEEDS_GCC_AT_LEAST_7
        depends on BR2_ARM_CPU_ARMV7A || BR2_ARM_CPU_ARMV8A
@@ -21,8 +21,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
        select BR2_TOOLCHAIN_HAS_FORTRAN
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2017.08 (based on gcc 6.4.1), Linaro GDB 2017.08 (based on
-         GDB 8.0), glibc 2.23, Binutils 2017.08 (based on 2.27). It
+         GCC 2017.11 (based on gcc 6.4.1), Linaro GDB 2017.11 (based on
+         GDB 8.0), glibc 2.23, Binutils 2017.11 (based on 2.27). It
          generates code that runs on all Cortex-A profile devices,
          but tuned for the Cortex-A9. The code generated is Thumb 2,
          with the hard floating point calling convention, and uses
index 664663df05ea77e9b8c528fe2e154b102797678b..42d6c3bf8f0be84f505fa32727ab6ab5dc6d61ed 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 a99029dff3d17d28c89831f2cd2aa37752c2f85fe89fe38fdd17971c36a9f1dc  gcc-linaro-6.4.1-2017.08-i686_arm-linux-gnueabihf.tar.xz
-sha256 1c975a1936cc966099b3fcaff8f387d748caff27f43593214ae6d4601241ae40  gcc-linaro-6.4.1-2017.08-x86_64_arm-linux-gnueabihf.tar.xz
+sha256 e088c71a4207a36beca9f3e60340ff7c678af53634765fc70865df80320dbdc7  gcc-linaro-6.4.1-2017.11-i686_arm-linux-gnueabihf.tar.xz
+sha256 1758d76daed9689e958668c3f2adef28c8c980b719d15594cbebfb5e5c4496f6  gcc-linaro-6.4.1-2017.11-x86_64_arm-linux-gnueabihf.tar.xz
index a165184b5b1ab43749d6945a04cc1f478304367f..61ffd25a40164b0d646c05acb3b6b75710831866 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION = 2017.08
+TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION = 2017.11
 TOOLCHAIN_EXTERNAL_LINARO_ARM_SITE = https://releases.linaro.org/components/toolchain/binaries/6.4-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)/arm-linux-gnueabihf
 
 ifeq ($(HOSTARCH),x86)