libsemanage: misc improvements
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Jan 2015 21:27:13 +0000 (22:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Jan 2015 21:27:13 +0000 (22:27 +0100)
This commit should have been part of the "libsemanage: new package"
commit, but due a mistake, the former commit was pushed before those
changes were squashed into it.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsemanage/Config.in
package/libsemanage/libsemanage.mk

index e4013cd226c5574ec0e7db247a5e231a93bfcc03..3f4bfb70a2133ecd27975f876881ff0cc8376c35 100644 (file)
@@ -16,15 +16,15 @@ config BR2_PACKAGE_LIBSEMANAGE
 
          http://selinuxproject.org/page/Main_Page
 
-comment "libsemanage needs a toolchain w/ largefile, threads"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_LARGEFILE
-
 if BR2_PACKAGE_LIBSEMANAGE
 
 config BR2_PACKAGE_LIBSEMANAGE_PYTHON_BINDINGS
-       select BR2_PACKAGE_PYTHON
+       depends on BR2_PACKAGE_PYTHON
        bool "python bindings"
        help
-         enable building python bindings
+         Enable building python bindings
 
 endif
+
+comment "libsemanage needs a toolchain w/ largefile, threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_LARGEFILE
index 55e5705c6c45b7ff4f93a20b07c37acb4ac0e46d..4813430d8defeaa92d377383f34ca2ab32647c77 100644 (file)
@@ -17,7 +17,7 @@ LIBSEMANAGE_MAKE_OPTS = $(TARGET_CONFIGURE_OPTS)
 
 ifeq ($(BR2_PACKAGE_LIBSEMANAGE_PYTHON_BINDINGS),y)
 
-LIBSEMANAGE_DEPENDENCIES += python host-swig host-python
+LIBSEMANAGE_DEPENDENCIES += python host-swig
 LIBSEMANAGE_MAKE_OPTS += \
        PYINC="-I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)/" \
        PYTHONLIBDIR="-L$(STAGING_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/" \
@@ -29,29 +29,29 @@ define LIBSEMANAGE_PYTHON_BUILD_CMDS
 endef
 
 define LIBSEMANAGE_PYTHON_INSTALL_STAGING_CMDS
-       $(MAKE) -C $(@D) install-pywrap $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(STAGING_DIR)
+       $(MAKE) -C $(@D) $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(STAGING_DIR) install-pywrap
 endef
 
 define LIBSEMANAGE_PYTHON_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) install-pywrap $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(TARGET_DIR)
+       $(MAKE) -C $(@D) $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install-pywrap
 endef
 
 endif # End of BR2_PACKAGE_PYTHON
 
 define LIBSEMANAGE_BUILD_CMDS
-       # DESTDIR is needed during the compile to compute library and 
+       # DESTDIR is needed during the compile to compute library and
        # header paths.
        $(MAKE) -C $(@D) $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(STAGING_DIR) all
        $(LIBSEMANAGE_PYTHON_BUILD_CMDS)
 endef
 
 define LIBSEMANAGE_INSTALL_STAGING_CMDS
-       $(MAKE) -C $(@D) install $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(STAGING_DIR)
+       $(MAKE) -C $(@D) $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(STAGING_DIR) install
        $(LIBSEMANAGE_PYTHON_INSTALL_STAGING_CMDS)
 endef
 
 define LIBSEMANAGE_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) install $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(TARGET_DIR)
+       $(MAKE) -C $(@D) $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
        $(LIBSEMANAGE_PYTHON_INSTALL_TARGET_CMDS)
 endef
 
@@ -59,13 +59,13 @@ HOST_LIBSEMANAGE_DEPENDENCIES = host-bison host-libsepol \
        host-libselinux host-ustr host-bzip2
 
 define HOST_LIBSEMANAGE_BUILD_CMDS
-       # DESTDIR is needed during the compile to compute library and 
+       # DESTDIR is needed during the compile to compute library and
        # header paths.
-       $(MAKE) -C $(@D) all $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR)
+       $(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR) all
 endef
 
 define HOST_LIBSEMANAGE_INSTALL_CMDS
-       $(MAKE) -C $(@D) install $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR)
+       $(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR) install
 endef
 
 $(eval $(generic-package))