package/lldpd: add optional libxml2 dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 7 Apr 2019 19:58:31 +0000 (21:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Apr 2019 17:31:24 +0000 (19:31 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lldpd/lldpd.mk

index 4e62f56c5d75819d4019e05d2475149851a97872..050f45491e70caae5d05d2a445a5022561669405 100644 (file)
@@ -29,7 +29,6 @@ LLDPD_CONF_ENV = ac_cv_prog_cc_c99=-std=gnu99
 
 LLDPD_CONF_OPTS = \
        --without-embedded-libevent \
-       --without-xml \
        --without-seccomp \
        --without-libbsd \
        --disable-hardening \
@@ -43,6 +42,13 @@ LLDPD_CONF_OPTS = \
        $(if $(BR2_PACKAGE_LLDPD_DOT3),--enable-dot3,--disable-dot3) \
        $(if $(BR2_PACKAGE_LLDPD_CUSTOM_TLV),--enable-custom,--disable-custom)
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+LLDPD_CONF_OPTS += --with-xml
+LLDPD_DEPENDENCIES += libxml2
+else
+LLDPD_CONF_OPTS += --without-xml
+endif
+
 ifeq ($(BR2_PACKAGE_NETSNMP),y)
 LLDPD_CONF_OPTS += --with-snmp
 LLDPD_DEPENDENCIES += netsnmp