package: remove redundant DISABLE_{IPV6,NLS,LARGEFILE} configure args
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Mar 2010 13:29:00 +0000 (14:29 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Mar 2010 13:29:00 +0000 (14:29 +0100)
Makefile.autotools.in automatically adds these to the configure invocation,
so there's no need to explicitly list them.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
14 files changed:
package/bind/bind.mk
package/e2fsprogs/e2fsprogs.mk
package/games/lxdoom/lxdoom.mk
package/grep/grep.mk
package/libcurl/libcurl.mk
package/libxml2/libxml2.mk
package/libxslt/libxslt.mk
package/lighttpd/lighttpd.mk
package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
package/multimedia/gst-plugins-base/gst-plugins-base.mk
package/multimedia/gst-plugins-good/gst-plugins-good.mk
package/multimedia/gst-plugins-ugly/gst-plugins-ugly.mk
package/php/php.mk
package/wget/wget.mk

index e1baef73ed56bf268da51377e6b121f62504adda..e57f26707bc5f3066d8b4328cea5688ad8ea4765 100644 (file)
@@ -16,7 +16,7 @@ BIND_TARGET_BINS = dig host nslookup nsupdate
 BIND_TARGET_LIBS = libbind9.* libdns.* libisccc.* libisccfg.* libisc.* liblwres.*
 BIND_CONF_ENV =        BUILD_CC="$(TARGET_CC)" \
                BUILD_CFLAGS="$(TARGET_CFLAGS)"
-BIND_CONF_OPT =        $(DISABLE_IPV6) \
+BIND_CONF_OPT =        \
                --sysconfdir=/etc \
                --localstatedir=/var \
                --with-randomdev=/dev/urandom \
index 5aa3261f9ed9c4b3fc80148d7234b44fb92ded63..21915ec790ce529a0a4d9e4a580aa10234f310e4 100644 (file)
@@ -21,9 +21,7 @@ E2FSPROGS_CONF_OPT = \
        --disable-resizer \
        --enable-fsck \
        --disable-e2initrd-helper \
-       --disable-testio-debug \
-       $(DISABLE_NLS) \
-       $(DISABLE_LARGEFILE)
+       --disable-testio-debug
 
 E2FSPROGS_MAKE_OPT = \
        LDCONFIG=true
index dd29cb9dba1aaee62d1c7697086f391c87b357b9..b9584b1fb9b9b8d418fbd921c6fe8c79d4666b25 100644 (file)
@@ -12,8 +12,7 @@ LXDOOM_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
 
 LXDOOM_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) --prefix=/usr \
-               --includedir=/usr/include --enable-shared \
-               $(DISABLE_NLS)
+               --includedir=/usr/include --enable-shared
 
 LXDOOM_DEPENDENCIES = xserver_xorg-server
 
index 868e460776cee22f50b8d8a0e0d0d0c0eae1e01d..acef6e9d2fe92e609c8f4171bf4f355c38dc23bc 100644 (file)
@@ -6,8 +6,7 @@
 GREP_VERSION:=2.5.3
 GREP_SOURCE:=grep-$(GREP_VERSION).tar.bz2
 GREP_SITE:=$(BR2_GNU_MIRROR)/grep
-GREP_CONF_OPT = --disable-perl-regexp --without-included-regex \
-       $(DISABLE_NLS) $(DISABLE_LARGEFILE)
+GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
 
 GREP_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),gettext libintl)
 
index cec6e74bdaf42e5d6ee4762e67e1c09302325ba8..863c30144139ee2cbea5a4d9f0295d6d0eb52fa6 100644 (file)
@@ -7,8 +7,7 @@ LIBCURL_VERSION = 7.19.2
 LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
 LIBCURL_SITE = http://curl.haxx.se/download/
 LIBCURL_INSTALL_STAGING = YES
-LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols \
-                  $(DISABLE_IPV6)
+LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBCURL_DEPENDENCIES += openssl
index 31fdabfa1ad84cbef2aba91e57e7867a51a08814..16f83a9f9535b9fd6f2441ad1c217f0057e0fcc5 100644 (file)
@@ -18,9 +18,9 @@ LIBXML2_USE_CONFIG_CACHE = NO
 endif
 
 LIBXML2_CONF_OPT = --with-gnu-ld --enable-shared \
-               --enable-static $(DISABLE_IPV6) \
+               --enable-static \
                --without-debugging --without-python \
-               --without-threads 
+               --without-threads
 
 HOST_LIBXML2_DEPENDENCIES = host-pkg-config
 
index 4bf61b54c55b7c034eb96fc19c874d3f638126a9..407924d4dc3eea054c34eeb9a13e117d6b533e89 100644 (file)
@@ -18,7 +18,6 @@ endif
 
 LIBXSLT_CONF_OPT = --with-gnu-ld --enable-shared \
                --enable-static $(LIBXSLT_XTRA_CONF_OPT) \
-               $(DISABLE_NLS) $(DISABLE_IPV6) \
                --without-debugging --without-python \
                --without-threads \
                --with-libxml-prefix=$(STAGING_DIR)/usr/
index b17f72c5f8723362d45f5c0c2b08dd519c443df5..1a2562cfcb1396eafdeed031387cc3fe43f32c63 100644 (file)
@@ -8,17 +8,12 @@ LIGHTTPD_VERSION = 1.4.26
 LIGHTTPD_SITE = http://download.lighttpd.net/lighttpd/releases-1.4.x
 LIGHTTPD_LIBTOOL_PATCH = NO
 
-ifneq ($(BR2_LARGEFILE),y)
-LIGHTTPD_LFS:=$(DISABLE_LARGEFILE) --disable-lfs
-endif
-
 LIGHTTPD_CONF_OPT = \
        --libdir=/usr/lib/lighttpd \
        --libexecdir=/usr/lib \
        --localstatedir=/var \
        --program-prefix="" \
-       $(DISABLE_IPV6) \
-       $(LIGHTTPD_LFS)
+       $(if $(BR2_LARGEFILE),,--disable-lfs)
 
 ifeq ($(BR2_PACKAGE_LIGHTTPD_OPENSSL),y)
 LIGHTTPD_DEPENDENCIES += openssl
index b6512470bf838ce5ee909357f5dfa30e588d668f..7a059c19b6b0aed6c949631d14b755aeec8da26b 100644 (file)
@@ -9,8 +9,6 @@ GST_PLUGINS_BAD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-bad
 GST_PLUGINS_BAD_LIBTOOL_PATCH = NO
 
 GST_PLUGINS_BAD_CONF_OPT = \
-               $(DISABLE_NLS) \
-               $(DISABLE_LARGEFILE) \
                --disable-examples
 
 GST_PLUGINS_BAD_DEPENDENCIES = gst-plugins-base gstreamer liboil
index bd422be0f60f1fd60eefb7587a076ea3f593becb..4d7f6dbc40cbf69e30092f6c36677d24a5060295 100644 (file)
@@ -15,8 +15,6 @@ GST_PLUGINS_BASE_LIBTOOL_PATCH = NO
 GST_PLUGINS_BASE_CONF_ENV = FT2_CONFIG=/bin/false
 
 GST_PLUGINS_BASE_CONF_OPT = \
-               $(DISABLE_NLS) \
-               $(DISABLE_LARGEFILE) \
                --disable-examples \
                --disable-x \
                --disable-xvideo \
index 19a53e6e28a6d4381c762abb1a037dd186948a77..c44bdff5079b6ef8a148a59e44c0afa5835514cf 100644 (file)
@@ -9,7 +9,6 @@ GST_PLUGINS_GOOD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-good
 GST_PLUGINS_GOOD_LIBTOOL_PATCH = NO
 
 GST_PLUGINS_GOOD_CONF_OPT = \
-               $(DISABLE_NLS) \
                --disable-debug \
                --disable-examples \
                --disable-directsound \
index 9440d24850f4829019565b9ee877405f0918ad0c..c87451fdf7e9a9bc1dcb365a7e51abcb9cfc9fe1 100644 (file)
@@ -9,7 +9,6 @@ GST_PLUGINS_UGLY_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-ugly
 GST_PLUGINS_UGLY_LIBTOOL_PATCH = NO
 
 GST_PLUGINS_UGLY_CONF_OPT = \
-               $(DISABLE_NLS) \
                --disable-examples
 
 GST_PLUGINS_UGLY_DEPENDENCIES = gstreamer gst-plugins-base
index 0747498f8590835617768dfb6ead0ebabd1d42d3..74fb4d9eedd6561f29d63e201220ec3cf86babbe 100644 (file)
@@ -12,8 +12,7 @@ PHP_INSTALL_STAGING_OPT = INSTALL_ROOT=$(STAGING_DIR) install
 PHP_INSTALL_TARGET_OPT = INSTALL_ROOT=$(TARGET_DIR) install
 PHP_LIBTOOL_PATCH = NO
 PHP_DEPENDENCIES =
-PHP_CONF_OPT = $(DISABLE_IPV6) \
-               --mandir=/usr/share/man \
+PHP_CONF_OPT =  --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --disable-all \
                --without-pear \
index cb0c60aa3676612d9e917522bed5aa6aca68bd9a..23c82af4f7f39b16ce585b818e2c5f71b3018323 100644 (file)
@@ -6,7 +6,6 @@
 
 WGET_VERSION = 1.12
 WGET_SITE = $(BR2_GNU_MIRROR)/wget
-WGET_CONF_OPT = $(DISABLE_IPV6)
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
        WGET_CONF_OPT += --with-ssl --with-libssl-prefix=$(STAGING_DIR)