package/qwt: add support for Qt5.
authorDavid PICARD <davepiq@yahoo.fr>
Thu, 24 Mar 2016 20:19:51 +0000 (21:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Mar 2016 09:46:28 +0000 (10:46 +0100)
This version of Qwt is compatible with both Qt and Qt5. This patch
adds the option to compile it for Qt5.

Signed-off-by: David Picard <davepiq@yahoo.fr>
[Thomas: slightly adjust the OpenGL dependencies.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qwt/Config.in
package/qwt/qwt.mk

index 876d465350b167b903cc3e649da4bcf02292ac19..6b394e3bc988d4059d110786e663b19019db88de 100644 (file)
@@ -1,7 +1,9 @@
 config BR2_PACKAGE_QWT
        bool "qwt"
-       depends on BR2_PACKAGE_QT
+       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
        select BR2_PACKAGE_QT_GUI_MODULE if BR2_PACKAGE_QT
+       select BR2_PACKAGE_QT5BASE_GUI if BR2_PACKAGE_QT5
+       select BR2_PACKAGE_QT5BASE_CONCURRENT if BR2_PACKAGE_QT5
        help
          Qwt is a graphics extension to the Qt GUI application
          framework. It provides a 2D plotting widget and more.
@@ -13,14 +15,16 @@ if BR2_PACKAGE_QWT
 config BR2_PACKAGE_QWT_SVG
        bool "SVG support"
        select BR2_PACKAGE_QT_SVG if BR2_PACKAGE_QT
+       select BR2_PACKAGE_QT5SVG if BR2_PACKAGE_QT5
 
 config BR2_PACKAGE_QWT_MATHML
        bool "MathML support"
 
 config BR2_PACKAGE_QWT_OPENGL
        bool "OpenGL support"
-       depends on BR2_PACKAGE_HAS_LIBGLES
-       depends on BR2_PACKAGE_HAS_LIBEGL
+       depends on (BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEG && BR2_PACKAGE_QT) || \
+               (BR2_PACKAGE_QT5_GL_AVAILABLE && BR2_PACKAGE_QT5)
        select BR2_PACKAGE_QT_OPENGL_ES if BR2_PACKAGE_QT
+       select BR2_PACKAGE_QT5BASE_OPENGL_LIB if BR2_PACKAGE_QT5
 
 endif
index 4d481fb90bcd701326f5ae9727ef481e57459fbb..594b1412c7edddce2c4d432bb8816a570b628ec2 100644 (file)
@@ -11,6 +11,9 @@ QWT_INSTALL_STAGING = YES
 ifeq ($(BR2_PACKAGE_QT),y)
 QWT_DEPENDENCIES = qt
 QWT_QMAKE = $(QT_QMAKE)
+else ifeq ($(BR2_PACKAGE_QT5),y)
+QWT_DEPENDENCIES += qt5
+QWT_QMAKE = $(QT5_QMAKE)
 endif
 
 QWT_LICENSE = LGPLv2.1 with exceptions