gutenprint: add optional libusb support
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 17 Apr 2016 19:35:38 +0000 (21:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 Apr 2016 19:35:38 +0000 (21:35 +0200)
As the recent build issues have shown, gutenprint has optional libusb
support so ensure it is built after libusb if enabled for consistent
builds.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gutenprint/gutenprint.mk

index aebafe2d63ea00282cba7ad588f324101a21dd6a..8ee2406abbbad34cd6f6131c0a3c793bc491f237 100644 (file)
@@ -16,7 +16,8 @@ GUTENPRINT_AUTORECONF = YES
 
 GUTENPRINT_DEPENDENCIES = \
        cups host-pkgconf \
-       $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+       $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
+       $(if $(BR2_PACKAGE_LIBUSB),libusb)
 
 # host-gutenprint is needed to generate XML as part of compilation
 # the program that generates the xml also links against libgutenprint