ffmpeg: add --pkg-config to configure options
authorDanomi Manchego <danomimanchego123@gmail.com>
Tue, 9 Sep 2014 02:06:46 +0000 (22:06 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Sep 2014 20:54:48 +0000 (22:54 +0200)
The ffmpeg does not understand the PKG_CONFIG env variable,
so it throws a line like this at the end of its configuration:

WARNING: .../output/host/usr/bin/arm-none-linux-gnueabi-pkg-config not found, library detection may fail.

Apparently, some of the indevs and outdevs need a pkg-config.
This patch adds the --pkg-config to let ffmpeg know where it
is.

[Thomas: remove unrelated formatting change.]

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.mk

index 1481abc8140acb72e480de73734fc21cc97619a0..c6f305a39a5676462edc4bf692f88766db42abe8 100644 (file)
@@ -64,7 +64,7 @@ FFMPEG_CONF_OPT = \
        --disable-symver \
        --disable-doc
 
-FFMPEG_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+FFMPEG_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv) host-pkgconf
 
 ifeq ($(BR2_ENABLE_DEBUG),y)
 FFMPEG_CONF_OPT += --enable-debug
@@ -333,6 +333,7 @@ define FFMPEG_CONFIGURE_CMDS
                --arch=$(BR2_ARCH) \
                --target-os="linux" \
                --disable-stripping \
+               --pkg-config="$(PKG_CONFIG_HOST_BINARY)" \
                $(if $(BR2_GCC_TARGET_TUNE),--cpu=$(BR2_GCC_TARGET_TUNE)) \
                $(SHARED_STATIC_LIBS_OPTS) \
                $(FFMPEG_CONF_OPT) \