package/x11r7/xserver_xorg-server: fix xlib_libXfont2 dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 5 Sep 2020 14:53:23 +0000 (16:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 6 Sep 2020 12:36:16 +0000 (14:36 +0200)
The dependency to xlib_libXfont2 was mistakenly removed in
https://git.buildroot.net/buildroot/commit/?id=e6dc4f1857eed27a19abd57fae7428bea38b69e5

Add it back again to fix build errors detected by the autobuilders and
remove handling of xlib_libXfont as well because only older versions of
xserver_xorg-server needed it.

Fixes:
http://autobuild.buildroot.net/results/f72/f72cc9b30e55e2c665de7a00482a1c3ba702118c/
http://autobuild.buildroot.net/results/9dd/9dd99e633dee8f11e7b2b973d4a72e51a2812ec9/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index d53083ef9016a8a1863382a0382aa4a64a2ac9c5..3bf5af89bee926af7abc530c23eb88774fc50be1 100644 (file)
@@ -22,6 +22,7 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
        select BR2_PACKAGE_XLIB_LIBXDMCP
        select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXFIXES
+       select BR2_PACKAGE_XLIB_LIBXFONT2
        select BR2_PACKAGE_XLIB_LIBXFT
        select BR2_PACKAGE_XLIB_LIBXI
        select BR2_PACKAGE_XLIB_LIBXINERAMA
index 53b05f0ffa8ca304278b17672cea1ad08d9748ee..de97467745c9fc9b21f72b069791ac7e71586fbf 100644 (file)
@@ -20,6 +20,7 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
        xlib_libXdmcp \
        xlib_libXext \
        xlib_libXfixes \
+       xlib_libXfont2 \
        xlib_libXi \
        xlib_libXrender \
        xlib_libXres \
@@ -160,14 +161,6 @@ else
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-libunwind
 endif
 
-ifeq ($(BR2_PACKAGE_XLIB_LIBXFONT2),y)
-XSERVER_XORG_SERVER_DEPENDENCIES += xlib_libXfont2
-endif
-
-ifeq ($(BR2_PACKAGE_XLIB_LIBXFONT),y)
-XSERVER_XORG_SERVER_DEPENDENCIES += xlib_libXfont
-endif
-
 ifneq ($(BR2_PACKAGE_XLIB_LIBXVMC),y)
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-xvmc
 endif