lighttpd: webdav locks require libuuid
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 23 Jul 2016 14:56:44 +0000 (11:56 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jul 2016 15:02:52 +0000 (17:02 +0200)
Since 1.4.40 webdav locks require libuuid from util-linux, so make it an
automatic dependency. Fixes:
http://autobuild.buildroot.net/results/b14/b14484300b4acfcaa18593b097167cef14330898/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lighttpd/lighttpd.mk

index 4a92a68dc1ade157a4ca45ea0f64259aaa4407ef..29d8634b99d2dc5aa358693fab622444cd70902f 100644 (file)
@@ -46,7 +46,13 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
 LIGHTTPD_DEPENDENCIES += libxml2 sqlite
-LIGHTTPD_CONF_OPTS += --with-webdav-props --with-webdav-locks
+LIGHTTPD_CONF_OPTS += --with-webdav-props
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+LIGHTTPD_CONF_OPTS += --with-webdav-locks
+LIGHTTPD_DEPENDENCIES += util-linux
+else
+LIGHTTPD_CONF_OPTS += --without-webdav-locks
+endif
 else
 LIGHTTPD_CONF_OPTS += --without-webdav-props --without-webdav-locks
 endif