python-sip: allow package to be built using Qt5
authorManuel Vögele <develop@manuel-voegele.de>
Fri, 19 Aug 2016 13:42:24 +0000 (15:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 19 Aug 2016 13:58:10 +0000 (15:58 +0200)
Signed-off-by: Manuel Vögele <develop@manuel-voegele.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-sip/Config.in
package/python-sip/python-sip.mk

index 45e48ad00ed1cdf78f916cc85349222c93e469f4..1f8961d0dfb76bc2e1e6e47264807841ea6b796b 100644 (file)
@@ -2,12 +2,17 @@ comment "python-sip needs a toolchain w/ C++, threads"
        depends on BR2_USE_MMU
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
 
+comment "python-sip needs qt or qt5"
+       depends on BR2_USE_MMU
+       depends on BR2_INSTALL_LIBSTDCPP && BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
+
 config BR2_PACKAGE_PYTHON_SIP
        bool "python-sip"
        depends on BR2_INSTALL_LIBSTDCPP # qt
        depends on BR2_TOOLCHAIN_HAS_THREADS # qt
        depends on BR2_USE_MMU # qt
-       select BR2_PACKAGE_QT
+       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
        help
          SIP is a tool that makes it very easy to create Python
          bindings for C and C++ libraries. It was originally
index d13801fb823dd7771ccac68733da89e569d99b6f..0c0a94738ddf211e726e29977d6eb7e0e90d8d0d 100644 (file)
@@ -10,7 +10,11 @@ PYTHON_SIP_SITE = http://downloads.sourceforge.net/project/pyqt/sip/sip-$(PYTHON
 PYTHON_SIP_LICENSE = SIP license or GPLv2 or GPLv3
 PYTHON_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
 
+ifeq ($(BR2_PACKAGE_QT5),y)
+PYTHON_SIP_DEPENDENCIES = qt5base
+else
 PYTHON_SIP_DEPENDENCIES = qt
+endif
 
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 PYTHON_SIP_DEPENDENCIES += python