linknx: needs argp-standalone on uClibc
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 3 May 2015 21:15:05 +0000 (23:15 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 3 May 2015 21:15:05 +0000 (23:15 +0200)
Fixes:
http://autobuild.buildroot.net/results/b27/b27c4b0822494fb393a5e28b8febd063222bd83f/
http://autobuild.buildroot.net/results/9db/9db2cc9fe6ddfda5663251872fdba00998020fce/
http://autobuild.buildroot.net/results/465/465328d0aa6b5f4b36903e2a4bc41d4ddd343db8/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linknx/Config.in
package/linknx/linknx.mk

index 6a26c207d54aa61ab6f3b503121f5219ba95035e..9982f3159d5f5a56973643caf55d543b8d015307 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_LINKNX
        bool "linknx"
        select BR2_PACKAGE_LIBPTHSEM
+       select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_MMU # libpthsem
        help
index a7e6adb22c25eb391b393d34ac2744d32a1a617c..7ecd947a7f56d8ffc0ec3d9390ae6650af8de0c5 100644 (file)
@@ -15,7 +15,7 @@ LINKNX_CONF_OPTS = \
        --with-pth=$(STAGING_DIR)/usr \
        --disable-smtp
 
-LINKNX_DEPENDENCIES = libpthsem
+LINKNX_DEPENDENCIES = libpthsem $(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
 
 ifeq ($(BR2_PACKAGE_MYSQL),y)
 LINKNX_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr/bin/mysql_config