ltp-testsuite: Add upstream patch to fix build numa detection
authorPetr Vorel <petr.vorel@gmail.com>
Tue, 30 Jan 2018 21:23:49 +0000 (22:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 30 Jan 2018 21:56:33 +0000 (22:56 +0100)
This removes fix added in commit 3c937807a3 ("ltp-testsuite: disable numa tests")

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ltp-testsuite/0002-numa-Fix-numa-v2-detection-for-cross-compilation.patch [new file with mode: 0644]
package/ltp-testsuite/ltp-testsuite.mk

diff --git a/package/ltp-testsuite/0002-numa-Fix-numa-v2-detection-for-cross-compilation.patch b/package/ltp-testsuite/0002-numa-Fix-numa-v2-detection-for-cross-compilation.patch
new file mode 100644 (file)
index 0000000..6ad1db0
--- /dev/null
@@ -0,0 +1,37 @@
+From 01c134f30be755a43af12a4ae2c31177d04be790 Mon Sep 17 00:00:00 2001
+From: Petr Vorel <pvorel@suse.cz>
+Date: Mon, 29 Jan 2018 10:31:40 +0100
+Subject: [PATCH] numa: Fix numa v2 detection for cross compilation
+
+Changed to AC_COMPILE_IFELSE as AC_RUN_IFELSE cannot be run while
+cross compiling.
+
+Bug found by Buildroot project.
+
+Signed-off-by: Petr Vorel <pvorel@suse.cz>
+Reported-by: Baruch Siach <baruch@tkos.co.il>
+---
+ m4/ltp-numa.m4 | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/m4/ltp-numa.m4 b/m4/ltp-numa.m4
+index fc3383e97..633f54c18 100644
+--- a/m4/ltp-numa.m4
++++ b/m4/ltp-numa.m4
+@@ -28,11 +28,11 @@ AC_DEFUN([LTP_CHECK_SYSCALL_NUMA], [
+       AC_CHECK_HEADERS([numa.h numaif.h], [], [have_numa_headers=no])
+       if test "x$have_numa_headers" != "xno"; then
+-              AC_RUN_IFELSE([AC_LANG_PROGRAM([
++              AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
+ #include <numa.h>
+               ], [
+ #if LIBNUMA_API_VERSION < 2
+-exit(1);
++# error Required numa headers >= 2
+ #endif
+               ])], [have_numa_headers_v2=yes])
+       fi
+-- 
+2.16.0
+
index 28dc24749ec88772be2941659849fcf669262f3b..5e0b35d12a22e296cdf12945a6cbbc3412b634df 100644 (file)
@@ -56,8 +56,10 @@ LTP_TESTSUITE_CONF_ENV += \
        CFLAGS="$(LTP_TESTSUITE_CFLAGS)" \
        CPPFLAGS="$(LTP_TESTSUITE_CPPFLAGS)" \
        LIBS="$(LTP_TESTSUITE_LIBS)" \
-       SYSROOT="$(STAGING_DIR)" \
-       have_numa_headers=no
+       SYSROOT="$(STAGING_DIR)"
+
+# Required by patch 0002-numa-Fix-numa-v2-detection-for-cross-compilation.patch
+LTP_TESTSUITE_AUTORECONF = YES
 
 # Requires uClibc fts and bessel support, normally not enabled
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)