package/lldpd: add optional netsnmp dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 7 Apr 2019 19:58:30 +0000 (21:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Apr 2019 17:31:19 +0000 (19:31 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lldpd/lldpd.mk

index 506b6f136d92631423b77f0e97b11af75f046866..4e62f56c5d75819d4019e05d2475149851a97872 100644 (file)
@@ -29,7 +29,6 @@ LLDPD_CONF_ENV = ac_cv_prog_cc_c99=-std=gnu99
 
 LLDPD_CONF_OPTS = \
        --without-embedded-libevent \
-       --without-snmp \
        --without-xml \
        --without-seccomp \
        --without-libbsd \
@@ -44,6 +43,15 @@ LLDPD_CONF_OPTS = \
        $(if $(BR2_PACKAGE_LLDPD_DOT3),--enable-dot3,--disable-dot3) \
        $(if $(BR2_PACKAGE_LLDPD_CUSTOM_TLV),--enable-custom,--disable-custom)
 
+ifeq ($(BR2_PACKAGE_NETSNMP),y)
+LLDPD_CONF_OPTS += --with-snmp
+LLDPD_DEPENDENCIES += netsnmp
+LLDPD_CONF_ENV += \
+       ac_cv_path_NETSNMP_CONFIG=$(STAGING_DIR)/usr/bin/net-snmp-config
+else
+LLDPD_CONF_OPTS += --without-snmp
+endif
+
 ifeq ($(BR2_PACKAGE_READLINE),y)
 LLDPD_CONF_OPTS += --with-readline
 LLDPD_DEPENDENCIES += readline