boot/beaglev-secondboot: update to 2d200479 to add LICENSE file
authorDrew Fustini <drew@beagleboard.org>
Wed, 9 Jun 2021 06:38:37 +0000 (23:38 -0700)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 13 Jul 2021 19:18:50 +0000 (21:18 +0200)
Update git commit ID to include recently added LICENSE file

Signed-off-by: Drew Fustini <drew@beagleboard.org>
Reviewed-by: Bin Meng <bmeng.cn@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
boot/beaglev-secondboot/beaglev-secondboot.hash
boot/beaglev-secondboot/beaglev-secondboot.mk

index e0ca0e149dabe6a3feefd84ad6af9ba9eb9ac809..efc93347b16c35657f45529d082ffd09e2eb9748 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed
-sha256  56519b20a8ac2b68770cacd5158190dfcb2b3762a759b1c44582ca25ffbccc5d  beaglev-secondboot-e976d186e69a1a84884265b0689626fa254a950d.tar.gz
+sha256  fe4d37f3ff38e7f2da70a08f9cb1668c0b928e85d2e0935bd985f910b3ce30e9  beaglev-secondboot-2d20047960044308126117ad56bc08a1164e82b2.tar.gz
+sha256  284d26192537710910ec1f112ec5f4c981601ae23702391986d6ce0b8ba90813  LICENSE
index 6d904b02ba3128baadbda7ba71acace0525cc065..a423c6c6a69770420406e87e2ae0dc0a18ef2832 100644 (file)
@@ -5,14 +5,13 @@
 ################################################################################
 
 # Commit on the 'starfive' branch
-BEAGLEV_SECONDBOOT_VERSION = e976d186e69a1a84884265b0689626fa254a950d
+BEAGLEV_SECONDBOOT_VERSION = 2d20047960044308126117ad56bc08a1164e82b2
 BEAGLEV_SECONDBOOT_SITE = $(call github,starfive-tech,beagle_secondBoot,$(BEAGLEV_SECONDBOOT_VERSION))
 BEAGLEV_SECONDBOOT_INSTALL_TARGET = NO
 BEAGLEV_SECONDBOOT_INSTALL_IMAGES = YES
 BEAGLEV_SECONDBOOT_DEPENDENCIES = host-riscv64-elf-toolchain
-# unfortunately, no real license file, but several sources files are
-# under GPL-2.0+, making the whole work GPL-2.0+
 BEAGLEV_SECONDBOOT_LICENSE = GPL-2.0+
+BEAGLEV_SECONDBOOT_LICENSE_FILES = LICENSE
 
 define BEAGLEV_SECONDBOOT_BUILD_CMDS
        $(MAKE) -C $(@D)/build \