shairport-sync: fix non-existent meta_dir member of shairport_cfg struct
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 21 Sep 2015 12:29:35 +0000 (13:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Sep 2015 13:08:44 +0000 (15:08 +0200)
shairport-sync tries to access to a non-existent member called
"meta_dir" of a "shairport_cfg" struct:

[snip]
if (config.meta_dir)
[snip]

That struct doesn't have that member so it causes a build failure like
this one:

mdns_tinysvcmdns.c: In function 'mdns_tinysvcmdns_register':
mdns_tinysvcmdns.c:121:13: error: 'shairport_cfg' has no member named
'meta_dir'
if (config.meta_dir)

This issue has been reported and fixed upstream:

  https://github.com/mikebrady/shairport-sync/issues/128#issuecomment-141947175

Fixes:

  http://autobuild.buildroot.net/results/89d/89d22ba2d41e05b407cde04c7e57510b36973ce9/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/shairport-sync/shairport-sync.mk

index dc36c0ea0dbc194a81e6f598f4dc3169d489c48f..36d5b8231088149f4b27dbc4849183943f824577 100644 (file)
@@ -10,6 +10,7 @@ SHAIRPORT_SYNC_SITE = $(call github,mikebrady,shairport-sync,$(SHAIRPORT_SYNC_VE
 SHAIRPORT_SYNC_LICENSE = MIT, BSD-3c
 SHAIRPORT_SYNC_LICENSE_FILES = LICENSES
 SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libconfig libdaemon popt host-pkgconf
+SHAIRPORT_SYNC_PATCH = https://github.com/mikebrady/shairport-sync/commit/6ae067af1f695e615415cde69a506ad330dbc45b.patch
 
 # Touching configure.ac with the patches
 SHAIRPORT_SYNC_AUTORECONF = YES