romfs: convert to ROOTFS_TARGET infrastructure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Mar 2010 23:14:06 +0000 (00:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:04:34 +0000 (11:04 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/romfs/romfs.mk

index e4b8ff58bbf1ee94f038b5b351b7a7e0be543931..971947880b7d19e26075ed3f279f7c730bcdf2a2 100644 (file)
@@ -6,28 +6,10 @@
 
 ROMFS_TARGET=$(IMAGE).romfs
 
-romfsroot: host-fakeroot host-genromfs makedevs
-       # Use fakeroot to pretend all target binaries are owned by root
-       rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-       touch $(BUILD_DIR)/.fakeroot.00000
-       cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-       echo "chown -R 0:0 $(TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-ifneq ($(TARGET_DEVICE_TABLE),)
-       # Use fakeroot to pretend to create all needed device nodes
-       echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
-               >> $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-endif
-       # Use fakeroot so genromfs believes the previous fakery
-       echo "$(HOST_DIR)/usr/bin/genromfs -d $(TARGET_DIR) -f $(ROMFS_TARGET)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-       chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-       $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
-       -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(ROMFS_TARGET))
+ROOTFS_ROMFS_DEPENDENCIES = host-genromfs
 
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_ROMFS),y)
-TARGETS+=romfsroot
-endif
+define ROOTFS_ROMFS_CMD
+       $(HOST_DIR)/usr/bin/genromfs -d $(TARGET_DIR) -f $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,romfs))
\ No newline at end of file