package/efl: keep X11 input 2.2+ enabled
authorRomain Naour <romain.naour@gmail.com>
Sat, 1 Aug 2020 14:20:35 +0000 (16:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 5 Aug 2020 13:31:09 +0000 (15:31 +0200)
Since efl 1.23, X11 input 2.2+ has been enabled by default [1].

>From [2]:
"It would be a pretty unusual system to have x and no xinput2.2 support."

While at it, enable explicitely X11 input 2 (enabled by default).

[1] https://git.enlightenment.org/core/efl.git/commit/?id=cf005ac54abdea843e5731765e41e5088275249f
[2] https://sourceforge.net/p/enlightenment/mailman/message/37065780/

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/efl/efl.mk

index 0ffbcf9f07ec5da87aadc27de7f664fe5d6118a4..6dc38b1626bed3904f325a853247c76d5c44aacc 100644 (file)
@@ -28,7 +28,6 @@ EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
 # Configure options:
 # elua=true: build elua for the target.
 # sdl=false: disable sdl2 support.
-# xinput22=false: disable X11 XInput v2.2+ support.
 # embedded-lz4=false: use liblz4 from lz4 package.
 # network-backend=none: disable connman networkmanager.
 EFL_CONF_OPTS = \
@@ -43,8 +42,7 @@ EFL_CONF_OPTS = \
        -Dnetwork-backend=none \
        -Dpixman=false \
        -Dsdl=false \
-       -Dvnc-server=false \
-       -Dxinput22=false
+       -Dvnc-server=false
 
 EFL_BINDINGS = luajit
 
@@ -154,7 +152,9 @@ EFL_CONF_OPTS += -Dfb=false
 endif
 
 ifeq ($(BR2_PACKAGE_EFL_X_XLIB),y)
-EFL_CONF_OPTS += -Dx11=true
+EFL_CONF_OPTS += -Dx11=true \
+       -Dxinput2=true \
+       -Dxinput22=true
 
 EFL_DEPENDENCIES += \
        xlib_libX11 \