wvstreams: fix openssl detection when statically linking
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 19 Jun 2013 21:55:29 +0000 (23:55 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 19 Jun 2013 21:56:41 +0000 (23:56 +0200)
The openssl tests need to link against libz as libcrypto references it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/wvstreams/wvstreams.mk

index d363f4c1d8e276eba5344d6b0bc9bfd40e575b9a..65f48d4037fae5c0cc87db1109e65ee034397eba 100644 (file)
@@ -24,6 +24,9 @@ WVSTREAMS_CONF_OPT += \
        --without-pam \
        --disable-warnings
 
+# needed for openssl detection when statically linking (as ssl needs lz)
+WVSTREAMS_CONF_ENV += LIBS=-lz
+
 ifeq ($(BR2_PACKAGE_DBUS),y)
        WVSTREAMS_DEPENDENCIES += dbus
        WVSTREAMS_CONF_OPT += --with-dbus