gconf: new package
authorJoseph Kogut <joseph.kogut@gmail.com>
Tue, 21 Nov 2017 02:02:58 +0000 (18:02 -0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Jan 2018 11:32:55 +0000 (12:32 +0100)
Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
[Thomas:
 - propagate dependencies of selected packages in Config.in
 - add missing Config.in comment about dependencies
 - add missing upstream URL in Config.in
 - add missing comment header in .mk file
 - remove --disable-nls from configuration options, it is taken care
   of by the package infrastructure
 - remove --disable-dependency-tracking, it is taken care of in the
   package infrastructure
 - add $(TARGET_NLS_DEPENDENCIES) to <pkg>_DEPENDENCIES, since gconf
   has optional NLS support
 - add host-intltool to <pkg>_DEPENDENCIES, since gconf needs
   intltool-update
 - fix license: it's LGPL-2.0+, not GPL-2.0.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/gconf/Config.in [new file with mode: 0644]
package/gconf/gconf.hash [new file with mode: 0644]
package/gconf/gconf.mk [new file with mode: 0644]

index 829c2d67d777bff63ac2973d9ea4be95ed75e58a..8e3e6b154540d922952ad6791b17af9741b7a5ea 100644 (file)
@@ -844,6 +844,7 @@ F:  board/qemu/ppc64le-pseries/
 F:     configs/qemu_ppc64le_pseries_defconfig
 
 N:     Joseph Kogut <joseph.kogut@gmail.com>
+F:     package/gconf/
 F:     package/python-raven/
 F:     package/python-schedule/
 F:     package/python-websockets/
index e6e37cff00c56073d59558398595d44b80985f08..b7ca5d7cbed63862b7a93a90d3b69e471b2c916d 100644 (file)
@@ -1456,6 +1456,7 @@ menu "Other"
        source "package/elfutils/Config.in"
        source "package/fftw/Config.in"
        source "package/flann/Config.in"
+       source "package/gconf/Config.in"
        source "package/gflags/Config.in"
        source "package/glibmm/Config.in"
        source "package/glm/Config.in"
diff --git a/package/gconf/Config.in b/package/gconf/Config.in
new file mode 100644 (file)
index 0000000..a682875
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_GCONF
+       bool "gconf"
+       depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
+       depends on BR2_USE_MMU # dbus, libglib2
+       depends on BR2_USE_WCHAR # libglib2
+       select BR2_PACKAGE_DBUS
+       select BR2_PACKAGE_DBUS_GLIB
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_LIBXML2
+       help
+         GConf was a system used by the GNOME desktop environment for storing
+         configuration settings for the desktop and applications. It is similar
+         to the Windows Registry.
+
+         https://projects.gnome.org/gconf/
+
+comment "gconf needs a toolchain w/ threads, wchar"
+       depends on BR2_USE_MMU
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
diff --git a/package/gconf/gconf.hash b/package/gconf/gconf.hash
new file mode 100644 (file)
index 0000000..24d0cf9
--- /dev/null
@@ -0,0 +1,4 @@
+# http://ftp.acc.umu.se/pub/gnome/sources/GConf/3.2/GConf-3.2.6.sha256sum
+sha256 1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c  GConf-3.2.6.tar.xz
+# License files, locally calculated
+sha256 94b03f1a60a7fd5007149530626a895a6ef5a8b9342abfd56860c5f3956f5d23  COPYING
diff --git a/package/gconf/gconf.mk b/package/gconf/gconf.mk
new file mode 100644 (file)
index 0000000..39df95f
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# gconf
+#
+################################################################################
+
+GCONF_VERSION = 3.2.6
+GCONF_SOURCE = GConf-${GCONF_VERSION}.tar.xz
+GCONF_SITE = http://ftp.gnome.org/pub/gnome/sources/GConf/3.2
+GCONF_CONF_OPTS = --disable-orbit
+GCONF_DEPENDENCIES = dbus dbus-glib libglib2 libxml2 \
+       host-intltool $(TARGET_NLS_DEPENDENCIES)
+GCONF_LICENSE = LGPL-2.0+
+GCONF_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))