transmission: install init script unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:47 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:26:10 +0000 (00:26 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/transmission/transmission.mk

index 27ad9d93e18bf06ed338c8a0788fc86dea2bf939..b8a5c429dacf70f236943d2424edb6e711502014 100644 (file)
@@ -37,9 +37,8 @@ ifeq ($(BR2_PACKAGE_TRANSMISSION_DAEMON),y)
        TRANSMISSION_CONF_OPTS += --enable-daemon
 
 define TRANSMISSION_INSTALL_INIT_SYSV
-       [ -f $(TARGET_DIR)/etc/init.d/S92transmission ] || \
-               $(INSTALL) -m 0755 -D package/transmission/S92transmission \
-                       $(TARGET_DIR)/etc/init.d/S92transmission
+       $(INSTALL) -m 0755 -D package/transmission/S92transmission \
+               $(TARGET_DIR)/etc/init.d/S92transmission
 endef
 
 else