flex: remove deprecated binary in target
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Jan 2015 14:30:21 +0000 (11:30 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Jan 2015 23:21:35 +0000 (00:21 +0100)
It's been deprecated for a year now so remove the option.

Also rename patch to new naming convention.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/flex/0001-prog-ar.patch [new file with mode: 0644]
package/flex/Config.in
package/flex/flex-prog-ar.patch [deleted file]
package/flex/flex.mk

index 243416ee52e7b51b907500a12935333bb9f9c7be..d6f32a0741fa1656c563ed5a2542b23379f08f5c 100644 (file)
@@ -102,6 +102,14 @@ endif
 
 comment "Legacy options removed in 2015.02"
 
+config BR2_PACKAGE_FLEX_BINARY
+       bool "flex binary in target option removed"
+       select BR2_LEGACY
+       help
+         The flex binary in the target option has been removed.
+         It's been deprecated for some time now and is essentially a
+         development tool which isn't very useful in the target.
+
 config BR2_PACKAGE_BISON
        bool "bison target package removed"
        select BR2_LEGACY
diff --git a/package/flex/0001-prog-ar.patch b/package/flex/0001-prog-ar.patch
new file mode 100644 (file)
index 0000000..e0626ff
--- /dev/null
@@ -0,0 +1,11 @@
+diff -rup flex-2.5.33.orig/Makefile.in flex-2.5.33/Makefile.in
+--- flex-2.5.33.orig/Makefile.in       2007-01-18 17:29:25.000000000 +0100
++++ flex-2.5.33/Makefile.in    2007-01-18 18:28:22.000000000 +0100
+@@ -105,7 +105,6 @@ am__installdirs = "$(DESTDIR)$(libdir)"
+       "$(DESTDIR)$(includedir)"
+ libLIBRARIES_INSTALL = $(INSTALL_DATA)
+ LIBRARIES = $(lib_LIBRARIES)
+-AR = ar
+ ARFLAGS = cru
+ libfl_a_AR = $(AR) $(ARFLAGS)
+ libfl_a_LIBADD =
index 9ac600da494185ea8e2381807f5731afa950bad4..7199c6a5830e8fe23771ea0c99a16e515633b479 100644 (file)
@@ -6,24 +6,3 @@ config BR2_PACKAGE_FLEX
          programs that perform pattern-matching on text.
 
          http://flex.sourceforge.net/
-
-if BR2_PACKAGE_FLEX
-
-config BR2_PACKAGE_FLEX_BINARY
-       bool "Install flex binary on target"
-       # needs fork()
-       depends on BR2_USE_MMU
-       # runtime dependency
-       select BR2_PACKAGE_M4
-       # development tool, useless on the target
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       depends on BR2_USE_WCHAR # m4
-       help
-         Install the flex binary tool in the target filesystem.
-
-comment "flex binary needs a toolchain w/ wchar"
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       depends on BR2_USE_MMU
-       depends on !BR2_USE_WCHAR
-
-endif
diff --git a/package/flex/flex-prog-ar.patch b/package/flex/flex-prog-ar.patch
deleted file mode 100644 (file)
index e0626ff..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -rup flex-2.5.33.orig/Makefile.in flex-2.5.33/Makefile.in
---- flex-2.5.33.orig/Makefile.in       2007-01-18 17:29:25.000000000 +0100
-+++ flex-2.5.33/Makefile.in    2007-01-18 18:28:22.000000000 +0100
-@@ -105,7 +105,6 @@ am__installdirs = "$(DESTDIR)$(libdir)"
-       "$(DESTDIR)$(includedir)"
- libLIBRARIES_INSTALL = $(INSTALL_DATA)
- LIBRARIES = $(lib_LIBRARIES)
--AR = ar
- ARFLAGS = cru
- libfl_a_AR = $(AR) $(ARFLAGS)
- libfl_a_LIBADD =
index cd92dd7b00f2ba3e7227de57deffdb8e9b61d995..9a3f840b112534ce3f95df804e146f377f95e848 100644 (file)
@@ -15,15 +15,6 @@ FLEX_CONF_ENV = ac_cv_path_M4=/usr/bin/m4
 # we don't have a host-gettext/libintl
 HOST_FLEX_DEPENDENCIES = host-m4
 
-ifeq ($(BR2_PACKAGE_FLEX_BINARY),y)
-# lex -> flex
-define FLEX_INSTALL_LEX
-       cd $(TARGET_DIR)/usr/bin && ln -snf flex lex
-endef
-FLEX_POST_INSTALL_HOOKS += FLEX_INSTALL_LEX
-
-else
-
 define FLEX_DISABLE_PROGRAM
        $(SED) 's/^bin_PROGRAMS.*//' $(@D)/Makefile.in
 endef
@@ -35,7 +26,5 @@ define FLEX_REMOVE_BROKEN_SYMLINK
 endef
 FLEX_POST_INSTALL_TARGET_HOOKS += FLEX_REMOVE_BROKEN_SYMLINK
 
-endif
-
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))