package/wireshark: add systemd optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 15 Apr 2019 16:10:58 +0000 (18:10 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 15 Apr 2019 22:22:14 +0000 (00:22 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wireshark/wireshark.mk

index 691f0140b5230fa2ef48c2fa03400839b3d86636..13da31d5c36cf2cacec3a6aa3c5b3ab32cd5b0c9 100644 (file)
@@ -18,8 +18,7 @@ WIRESHARK_MAKE_ENV = \
 WIRESHARK_CONF_OPTS = \
        -DENABLE_PCAP=ON \
        -DENABLE_SMI=OFF \
-       -DENABLE_STATIC=OFF \
-       -DBUILD_sdjournal=OFF
+       -DENABLE_STATIC=OFF
 
 # wireshark needs the host version of lemon during compilation.
 # This binrary is provided by sqlite-src (which is different from
@@ -141,6 +140,13 @@ else
 WIRESHARK_CONF_OPTS += -DENABLE_SPANDSP=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+WIRESHARK_CONF_OPTS += -DBUILD_sdjournal=ON
+WIRESHARK_DEPENDENCIES += systemd
+else
+WIRESHARK_CONF_OPTS += -DBUILD_sdjournal=OFF
+endif
+
 define WIRESHARK_REMOVE_DOCS
        find $(TARGET_DIR)/usr/share/wireshark -name '*.txt' -print0 \
                -o -name '*.html' -print0 | xargs -0 rm -f