package/wavpack: add openssl optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 18 Dec 2019 22:23:19 +0000 (23:23 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 19 Dec 2019 13:04:24 +0000 (14:04 +0100)
wavpack optionally depends on libcrypto since version 5.2.0 and
https://github.com/dbry/WavPack/commit/e158df5353b57ac7002d5cac4b3a040eba4c0c9f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wavpack/wavpack.mk

index 9246b95397e5783350d86a1fa977b0bedf00d1fd..8cb7754b2b34f95afff58d8b39adfc25aec13568 100644 (file)
@@ -17,6 +17,13 @@ ifeq ($(BR2_PACKAGE_LIBICONV),y)
 WAVPACK_CONF_OPTS += LIBS=-liconv
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+WAVPACK_DEPENDENCIES += openssl
+WAVPACK_CONF_OPTS += --enable-libcrypto
+else
+WAVPACK_CONF_OPTS += --disable-libcrypto
+endif
+
 # WavPack "autodetects" CPU type to enable ASM code. However, the assembly code
 # for ARM is written for ARMv7 only and building WavPack for an ARM-non-v7
 # architecture will fail. We explicitly enable ASM for the supported