linux-pam: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:55:18 +0000 (22:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:44 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-pam/Config.in
package/linux-pam/linux-pam.mk

index ab7cf5595270796b781b9f4e88639b6d09c40cd4..33e515434bfb3ad957c316da8cee01390896cce4 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_LINUX_PAM
        depends on !BR2_STATIC_LIBS
        depends on !BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_USE_MMU # fork()
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        select BR2_PACKAGE_FLEX
        help
          A Security Framework that Provides Authentication for Applications
index fb2f99cb1feae98cd49bfe44e0aa889f1a7d93c2..5c80e7841617d4d7c2fd970efb478a86ee541e88 100644 (file)
@@ -16,15 +16,12 @@ LINUX_PAM_CONF_OPTS = \
        --disable-regenerate-docu \
        --enable-securedir=/lib/security \
        --libdir=/lib
-LINUX_PAM_DEPENDENCIES = flex host-flex host-pkgconf
+LINUX_PAM_DEPENDENCIES = flex host-flex host-pkgconf \
+       $(TARGET_NLS_DEPENDENCIES)
 LINUX_PAM_AUTORECONF = YES
 LINUX_PAM_LICENSE = BSD-3-Clause
 LINUX_PAM_LICENSE_FILES = Copyright
-
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-LINUX_PAM_DEPENDENCIES += gettext
-LINUX_PAM_MAKE_OPTS += LIBS=-lintl
-endif
+LINUX_PAM_MAKE_OPTS += LIBS=$(TARGET_NLS_LIBS)
 
 ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
 LINUX_PAM_CONF_OPTS += --enable-selinux